Support

Home Forums Event Espresso Premium Registration Approved message not sent after several failed payments

Registration Approved message not sent after several failed payments

Posted: March 11, 2020 at 8:02 am


echobrin

March 11, 2020 at 8:02 am

We have had this happen twice now. A user registered for an event and tried to pay via PayPal. The message log shows two Payment Declined messages, followed by a Payment Received message. The registration was approved but the Registration Approved messages were not sent. I saw this thread https://eventespresso.com/topic/registration-approved-email-didnt-send/ but it doesn’t seem to apply since we are using version 4.10.3.p.


Josh

  • Support Staff

March 11, 2020 at 11:24 am

Hi,

May I ask which PayPal payment method? Express Checkout, Standard, Smart buttons, or Pro?


echobrin

March 11, 2020 at 11:34 am

PayPal Express


Josh

  • Support Staff

March 11, 2020 at 5:57 pm

Can you go to the Event Espresso > Transactions page and find the transaction, then click the icon? Which message types are listed there?


echobrin

March 12, 2020 at 7:27 am

Payment Declined, Payment Declined, Payment Received, all from the original transaction date of 2/17. Then from yesterday Registration Approved (Registrant and Event Admin) that I triggered myself.


Josh

  • Support Staff

March 18, 2020 at 12:09 pm

Hi,

I’m sorry for the delayed reply. I took some time to set up a PayPal sandbox account with negative testing and tested some failed (declined) transactions. Then switched negative testing off so the next payment would go through. I could not replicate the issue, the Reg. Approved emails do get sent after several failed payments are followed by a successful payment in a transaction.

Can you check your settings in Event Espresso > Messages > Settings, what’s set for “Generate and send all messages:”?


echobrin

March 18, 2020 at 1:01 pm

On a separate request


Josh

  • Support Staff

March 18, 2020 at 1:17 pm

Can you get the error code from the entry in Event Espresso > Transactions? The first payment attempt should should have a code under “Gateway Response”. I’m not sure if the type of decline would make a difference, but we could try testing the same type of failure.


echobrin

March 18, 2020 at 1:23 pm

10486; This transaction couldn’t be completed.


Josh

  • Support Staff

March 18, 2020 at 4:52 pm

I tested a transaction and forced a 10486 error where the first payment was declined, then on the last attempt made a payment that was accepted;
https://slack-files.com/T02SY781D-F0109SSGRU4-df7851390b
and the emails went out as expected.
https://slack-files.com/T02SY781D-F010C6SNZJT-22be9c77dc

I’m really not sure why all the emails did not go out on your site. If I come across anything else that could be checked I will let you know.


echobrin

March 18, 2020 at 5:13 pm

Thanks for looking into it. I’ll keep an eye on it for now. We do have text that instructs people to contact us if they don’t receive their registration details within 24 hrs, but not all of them do. I just enabled the event admin context for payment received messages since those seem to be going out consistently and it would give me a heads up to look out for a corresponding registration approved message.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  echobrin 1 week, 4 days ago ago

Topic Tags

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!