Support

Home Forums Event Espresso Premium Need help determining cause of email issue

Need help determining cause of email issue

Posted: October 1, 2018 at 7:08 am


robert sirkis

October 1, 2018 at 7:08 am

I had lots of issues last night. Need help resolving.

Issue 1 – All of the sudden in the middle of opening registration for my event my attendees received the below error:

An error has occurred:
The WordPress wp_mail function is used for sending emails but does not give any useful information when and email fails to send.
It is possible the “to” address (xxx@email.com) or “from” address (xxx@email.com) is invalid.

Both emails are correct. Not sure where the failure would be or where to look.

This issue caused people to register multiple times and I spend a lot of time double checking registrations and processing multiple refunds.

Issue 2 – No one is receiving confirmation emails. They are just queued up when I look at ‘Messages’

Issue 3 – Intermittently attendees are not getting “Approved” status after the payment has been processed. They are stuck in “Pending Payment” and I have to manually update their status. What could be causing this issue?

Issue 4 – I only had about 130 registrations last night but it took many people upwards of 20-30 minutes to complete registration. When it is just a few people at a time it is ok. But I am seeing issues when only 50 people are registering at the same time. I’m positive this is documented somewhere, but what minimum requirements should my website use?

Please email me if you need login credentials. Thanks!


Josh

  • Support Staff

October 1, 2018 at 9:47 am

Hi Robert,

May I ask are you using the web host’s provided email server or are you using a transactional email service? If the former, the way forward will be to use a transactional email service. Here’s link to a guide that has some recommendations:

http://eventespresso.com/wiki/postmark-app-mandrill-transactional-email-handling-services/

Issue 3 – Intermittently attendees are not getting “Approved” status after the payment has been processed. They are stuck in “Pending Payment” and I have to manually update their status. What could be causing this issue?

It could be the payment gateway isn’t sending payment notifications promptly. May I ask which payment method is being used on the site? E.g PayPal standard, Authorize.net, or other?

Issue 4 – I only had about 130 registrations last night but it took many people upwards of 20-30 minutes to complete registration. When it is just a few people at a time it is ok. But I am seeing issues when only 50 people are registering at the same time. I’m positive this is documented somewhere, but what minimum requirements should my website use?

We do not actually document hard requirements because any number of factors will vary. What I can recommend is reach out to the host, let them know that your site is slowing down when there are around 50 simultaneous e-commerce transactions, and they should be able to host your site on a hosting plan that will provide enough resources for that amount of traffic.


robert sirkis

October 1, 2018 at 10:00 am

I was using the web host email. I’ll give the transaction email service a shot. But I would like to know why it was working, and then all of the sudden it stopped working. I did find it odd that when I tried to reset my password for EE this morning, and entered my email address, I got a very similar error message. There was no issue when I used my user name.

I am using Stripe for the payment gateway.

I’ll reach out to the host.


Josh

  • Support Staff

October 1, 2018 at 10:07 am

But I would like to know why it was working, and then all of the sudden it stopped working.

Usually that’s an indication that something on your site’s server side has changed. That could be a new plugin, an updated plugin, or even at a lower level where the web host updated software on the server, for example.


robert sirkis

October 1, 2018 at 10:17 am

Nothing changed and nothing was added or updated. It was working and then stopped working between 6p and 7p cst last night.


Josh

  • Support Staff

October 1, 2018 at 10:26 am

May I ask how do you know nothing was changed on the server at the lower level? In any case, your host may be able to check through the logs on the server to get a better idea of what happened last night.


robert sirkis

October 1, 2018 at 10:28 am

Because I am the only admin and didn’t change anything. I don’t have anything set to auto-update either.


Josh

  • Support Staff

October 1, 2018 at 10:36 am

Your host may have updated some software at the lower level (e.g the PHP version, the email server, maintenance and so on).


robert sirkis

October 1, 2018 at 10:54 am

Email issue is with flywheel. There is a setting that turned off emails because of the amount of emails we were generating (about 100) in a short amount of time.


robert sirkis

October 1, 2018 at 11:03 am

Looks like the only open item is below

Issue 3 – Intermittently attendees are not getting “Approved” status after the payment has been processed. They are stuck in “Pending Payment” and I have to manually update their status. What could be causing this issue?

It could be the payment gateway isn’t sending payment notifications promptly. May I ask which payment method is being used on the site? E.g PayPal standard, Authorize.net, or other?

Stripe is what we are using.


Josh

  • Support Staff

October 1, 2018 at 11:25 am

Can you check to make sure the Thank You page is not being served from a cache? When the ticket buyer submits the Stripe payment form, there’s some processing that happens and after there’s a response from Stripe they’re forwarded to the Thank You page which will load up their payment information.

That page needs to be served dynamically. If it’s served from a cached file they’ll not get the correct information about their transaction.


robert sirkis

October 1, 2018 at 11:51 am

Is this something I need to check with the host?


Josh

  • Support Staff

October 1, 2018 at 11:54 am

Yes.

The support post ‘Need help determining cause of email issue’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 2 weeks, 4 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!