Support

Home Forums Multiple Event Registration Add-on Multi Registration Payment Stalling

Multi Registration Payment Stalling

Posted: March 3, 2021 at 6:01 pm


BradSalon

March 3, 2021 at 6:01 pm

I have the registration and payment system working, students are buying classes and I can buy test events. However, if I add more than one event at a time it will let me get all the pay till the “Pay Now” button and when I click it nothing happens and it just hangs there, no error message. It takes the little payment section away and just has the card selector and the “proceed to finalize registration” button which is greyed out. Love any help to make this work.


Tony

  • Support Staff

March 4, 2021 at 9:45 am

Hi there,

Can you link me to an event I can use to test/view this?


BradSalon

March 4, 2021 at 6:44 pm

Thanks for taking a look!
https://rootsvt.com/events/test-3/
https://rootsvt.com/events/test-2/


Tony

  • Support Staff

March 5, 2021 at 3:19 pm

Hmm, ok. Something odd going on here.

Have you changed any of the templates used by your theme?

Or added any custom code to modify what EE outputs to the pages?

EE injects some placeholder elements into the top of the page which it uses to then display messages to the user (payment error/success messages, contextual info like a field is missing a value etc). On your site, those elements aren’t being added, thats common with page builders but when I use Divi on a test site I don’t run into the same problem, although I’m not using Divi Builder which I assume you are?


BradSalon

March 7, 2021 at 6:16 am

I am using the divi builder for a custom global header. I have not done anything but make it so that the pop up window does not display “Go back to event list” because I am not using the event list to display events, just the table view and the individual event pages. I didn’t mess with the php but I have had issues with the hosting company and with the site and they may have messed with something I guess in trying to “fix” it. Anything I should be asking them?


Tony

  • Support Staff

March 8, 2021 at 5:19 am

Hmm, they shouldn’t really have set anything that would change this.

May I ask what the issues were?

Can you send me the copy of Divi you are using and Divi builder so I can test this locally?


BradSalon

March 10, 2021 at 5:47 am

The issues involved them setting up the build site initially with a strange file structure and then when it was copied for the live site issues came up. Finally they asked me to deactivate some plugins and delete unused plug ins and the site when down. They then did something to fix it but when they were done the cart widget was missing from the footer where I put the widget. I had not yet tested multiple registrations at this point so I dont know if it was working before. I am using Divi Version: 4.9.1, which includes the builder.


Tony

  • Support Staff

March 10, 2021 at 8:39 am

Ok, so I wouldn’t consider the above ‘normal’ but I obviously don’t know enough to comment further, it just sounds odd.

I am using Divi Version: 4.9.1, which includes the builder.

I don’t use Divi so I don’t have access to it other than what I’ve been sent from users to check issues, can you send me a copy over so I check this locally?


BradSalon

March 10, 2021 at 9:00 am

It has been a hard process with the hosting company…I am not a developer, I am just trying to make a basic site with event espressso for my business. Every company and plugin tends to say something different. If you see an issue that is somehow related to hosting etc then please let me know so I can ask them to change or fix the issue.

As for divi, I dont know how to send a copy of divi over so you can check it locally. Do you mean a copy of my theme files or something? Clearly I am wandering in the dark here. I did not know that plugins have so many issues preforming or conflicting with themes and other plugins so I am just trying to find my way through it all. Thanks again for any help.


Tony

  • Support Staff

March 10, 2021 at 2:46 pm

Every company and plugin tends to say something different.

Tailoring themes and plugins to work on every host is tough, as they all do things a little differently and have caching setup for X,Y and Z that may need disabling and some disable features for ‘security’ and so on.

I try to stay out of X host is good and Y host is bad as its very subjective, the good and the bad changes from person to person AND site to site.

Do you mean a copy of my theme files or something?

Pretty much yeah, the .zip file you got from elegant themes and then installed on the site.

Basically, I don’t want to just throw code at yo saying try this and try that to see if it fixes it without knowing what the problem is. I can’t troubleshoot that directly on your site but if I can test locally can usually narrow down the problem.


BradSalon

March 10, 2021 at 3:04 pm

Okay what is the best way to send the .zip, I have it uploaded to drive.


Tony

  • Support Staff

March 10, 2021 at 3:29 pm

Either post the link here in a private reply or send it to support[at]eventespresso.com and I’ll take a look there.


BradSalon

March 12, 2021 at 8:52 am

I sent it to the email, please let me know if you dont get it or if you need anything else.


BradSalon

March 12, 2021 at 1:39 pm

Any news with this? I am having students having issues with this and would like to try and fix it.


BradSalon

March 12, 2021 at 1:48 pm

FYI when you try and add more than one program and then check out it says there are no events in your cart


Tony

  • Support Staff

March 15, 2021 at 10:18 am

Hi Brad,

Just noting that we have received your support token request and replied directly via email.


BradSalon

March 17, 2021 at 6:43 pm

I have stopped receiving replied via email…


Tony

  • Support Staff

March 18, 2021 at 8:23 am

Hi Brad,

My apologies for the delayed reply, I’ve just replied directly via email.


BradSalon

March 19, 2021 at 3:24 pm

This issue is not resolved as students are still unable to register for multiple programs. Please advise what information I need to get from them in order to help resolve the issue. Thank you.


Tony

  • Support Staff

March 22, 2021 at 11:02 am

Hi there,

Just noting here that I have replied to your support token via email.

The support post ‘Multi Registration Payment Stalling’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!