Support

Home Forums Event Espresso Premium Emails are not being sent out

Emails are not being sent out

Posted: June 7, 2018 at 11:12 am


clifford choi

June 7, 2018 at 11:12 am

I’m running WordPress version 4.9.6 and Event Espresso Version 4.9.62.p

The emails I’m trying to send out are tagged orange
http://www.copadehk.com/wp-content/uploads/2018/06/Screenshot-2018-6-8-‹-Copa-De-Hong-Kong-—-WordPress.png

I don’t know what that means or what to do. Please help!

Thanks!


clifford choi

June 7, 2018 at 11:12 am

The website is http://www.copadehk.com

Thanks!


Josh

  • Support Staff

June 7, 2018 at 12:07 pm

Hi there

It means Failed Sending, Can be retried. If you hit the double arrow icon does the message send?

If not, if you go to test an email from one of the email Message template editors, do you receive the test? If so, it may help to go to Event Espresso > Messages > Message Settings and set the the option for emails to be sent on the same request.

If not, can you verify whether *other* emails (like a WordPress password reset email) get sent from your site?

You can install this plugin to possible capture errors when there’s an attempt to send an email:
https://wordpress.org/plugins/wp-mail-logging/

In most cases, setting up a third party service to deliver email will resolve email delivery issues. The built-in mail servers (especially those that are used for shared hosting accounts) can be unreliable. We recommend using a service like Mandrill, Postmark, or any of the other services listed in our documentation for sending transactional email. More info here:

http://eventespresso.com/wiki/postmark-app-mandrill-transactional-email-handling-services/

Alternatively, you could also use a gmail account and configure a plugin like the WP Mail SMTP plugin to send the emails.


clifford choi

June 8, 2018 at 12:10 am

Hi Josh!

Thank you for such an elaborate explanation!

I had to go through your list until the very last one, to install the WP Mail SMTP plugin. I realized that the plugin was installed but the credentials were all wrong. As soon as I fixed it and sent a test email, everything worked!

Thank you so much Josh! You’re the best!

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  clifford choi 1 week, 5 days ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!