Support

Home Forums Translations used POedit, doesn't work. help?

used POedit, doesn't work. help?

Posted: May 31, 2015 at 9:18 am


Nik24nik

May 31, 2015 at 9:18 am

Dear Event Espresso team,
thank you in advance for your help.
I’ve found a lot of very useful resources through this forum and they’ve helped me a great deal.
Today unfortunately, even though I followed the instructions I found on
this page
I wasn’t unable to make it work.
For some reason nothing changes on my website, no matter what I write on POedit.
I suspect it has something to do with the fact that I didn’t have a “languages” folder in my “uploads/espresso” folder. I had to create it.
Also, I’m not sure the .mo and .po files I put there are named correctly.
Is there some specific name I need to give to the files to make them recognised for the en_UK language I set in the wp-config.php?

Any help will be greatly appreciated.
Please let me know if you need any more info.


Tony

  • Support Staff

May 31, 2015 at 3:07 pm

Hi Nik,

Can you tell me the exact version number of Event Espresso your are using please?

Can you also post the full filename of po/mo files.

Finally what site language do you have selected within Dashboard -> Settings.


Nik24nik

June 2, 2015 at 2:00 pm

Hi Tony,
thank you for your reply.
here’s the answers you need:
Event Espresso version: 4.6.24.p
PO file name: event-espresso-4-en_UK.po
MO file name: event-espresso-4-en_UK.mo
Site Language: It was English United States (Even though I’ve set En_UK in the wp-config.php file). After reading this note from WP though “Note: The WPLANG constant in your wp-config.php file is no longer needed.” I have now changed it to En_UK, but still couldn’t see any change to the words in Event Espresso events.

here’s a link of an event from Event Espresso: http://warrenbusinessconsulting.com/events/essentials-of-oil-gas-commercial-contracts-negotiations-erbil/
Every “Registration” should become “Booking”, in theory.

Thank you for your help.
Nik


Lorenzo Orlando Caum

  • Support Staff

June 2, 2015 at 2:14 pm

Hi Nik, could you please update to the current version of Event Espresso 4?

http://eventespresso.com/wiki/ee4-changelog/

Next, did you get the latest language files from our project on GlotPress?

http://translate.eventespresso.com/projects/event-espresso-4/en-gb/event-espresso-en_GB


Lorenzo


Nik24nik

June 8, 2015 at 4:10 pm

Hi Lorenzo,
I’ve updated EE and somehow it works now.
I’m not sure why updating it did the trick, but it did, so I’m happy.

thank you for the help.

The support post ‘used POedit, doesn't work. help?’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Nik24nik 5 years, 7 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!