Support

Home Forums Event Espresso Premium Trouble integrating Stripe Payment gateway

Trouble integrating Stripe Payment gateway

Posted: April 11, 2018 at 11:54 am


IIES

April 11, 2018 at 11:54 am

I have an EE4 personal licence and had to pay for the Stripe payment gateway. I followed the steps to integrate it but I still have a message on WP that says “There are no Active Payment Methods setup for Event Espresso. Please activate at least one”. When I click that link it only gives me the payment options included with my version, ie. Authorize.net AIM|Bank|Check|Invoice|Mijireh|PayPal Express|Paypal Pro. Stripe Payments however shows up on my dashboard. When I click on it I get the option to add new product, orders and settings. I’ve added the secret and public keys and everything looks as if it will work. I am not selling products, I just want a payment option for when they register for events. HOW DO I INTEGRATE THIS?


Tony

  • Support Staff

April 11, 2018 at 1:35 pm

Hi there,

It sounds like you’ve install a different Stripe plugin.

If you go to Dashboard -> Plugins, find the Stripe plugin you installed, what does it show up as?

Is should show as ‘Event Espresso – Stripe Gateway (EE 4.6.0+)’, like so – http://take.ms/lqReZ


Josh

  • Support Staff

April 11, 2018 at 1:36 pm

Hi there,

You can follow the steps in this guide:

https://eventespresso.com/wiki/stripe-payment-gateway/

Please be sure to install the Event Espresso 4 Stripe add-on that you can download from your account page. The Stripe payments settings you’re currently seeing in your WordPress Dashboard is quite likely from a different plugin that does not integrate with Event Espresso.


IIES

April 12, 2018 at 10:16 am

1. On my EE account page I see: Your Active Subscriptions:
EE4 Stripe Payment Gateway, and when I click the link, I get a msg that says “You have access to this product already, and you can download this product from your account page”.
2. On Account Page It says that I have “EE4 Stripe Payment Gateway v1.1.2.p
Expires: 2019-04-04 (UTC)” downloaded.
3. Then: “Login to your WordPress dashboard (WP-admin) and go to Plugins. Next, click on Add New –> Upload and browse to the plugin on your computer. Then select the zip file and begin the upload process. Wait for the plugin to upload and then click on Activate.”
When I do this, I get a number of different Stripe payment gateway options. WooCommerce Stripe payment gateway; stripe PayPal; stripe payments (the one I downloaded the zip file for and that shows up on my WP dashboard); stripe payments for WordPress WP Simple Pat; gravity forms+stripe; stripe checkout. The list goes on…Which one do I install? I’ve paid for it so where is it?


Josh

  • Support Staff

April 12, 2018 at 10:42 am

It’s the one you downloaded the zip file for. If you haven’t uploaded it to your site yet, you click on the Upload Plugin button on the WordPress > Plugins > Add New page. You won’t find the Stripe plugin in a search on the Plugins > Add New page, you will need to upload the zip file. After you click the Upload Plugin button, you’ll follow the prompts to upload, install, and activate.

If you have uploaded it, then you go to WordPress > Plugins and click the Activate link under this listing:
> Event Espresso – Stripe Gateway (EE 4.6.0+)

Once you have the plugin installed and activated, you can head over to Event Espresso > Payment Methods and activate the Stipe Payment method for Event Espresso.


IIES

April 12, 2018 at 10:52 am

Hi again, thank you I was able to download the correct stripe. Now i am setting up things up with stripe. when I click the connect with stripe button, type in my credentials i get a message saying “is this the correct URL for your site”, this however does not include the https in front it just says my site ____.com when I click “yes complete the authentication process” I get an error message , “This page isn’t working
If the problem continues, contact the site owner.
HTTP ERROR 414”
What can I do now?


Josh

  • Support Staff

April 12, 2018 at 12:25 pm

That sounds like you have the iThemes security plugin set to filter long URL strings. Can you go to the iThemes security plugin’s settings page, then go to System Tweaks, then uncheck the box next to Filter Long URL Strings, then save? You should be able to connect to Stripe after that setting is deactivated.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Josh 2 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!