Support

Home Forums Event Espresso Premium This page didn't load Google Maps correctly…

This page didn't load Google Maps correctly…

Posted: February 23, 2017 at 2:54 pm


Alyssainmontana1

February 23, 2017 at 2:54 pm

I have just gone the process of obtaining an API key with my Google account 2x now, and I have read over a number of forum communications on this, and I am very sure I have entered the referring website with Google very carefully starting with the asterisk, followed by a period, then the domain name, forward slash and asterisk, and I still get the error in Espresso that “Oops! Something went wrong. This page didn’t load Google Maps correctly. See the JavaScript console for technical details.” Well, I don’t know how to see the JavaScript console… I am new to building websites. Please help! Thank you!


Tony

  • Support Staff

February 23, 2017 at 3:11 pm

Hi there,

Can you link us to a page we can view the map on please? I’ll tell you the error from the console.

At a guess I would say the ‘referrer’ is wrong, the example google give is a little misleading so its common to be set wrong.


Alyssainmontana1

February 23, 2017 at 4:18 pm

Thank you for the quick response. Here are the links for the 2 event pages which show their respective venues that should show the Google Map.

http://improveucourses.com/events/inside-the-circle-communication-casper/
http://improveucourses.com/events/inside-the-circle-communication-cheyenne/

I hope this will help you to figure this out. Thank you!


Tony

  • Support Staff

February 23, 2017 at 5:23 pm

Ok so the error message is Google Maps API error: RefererNotAllowedMapError

http://take.ms/g4sgb

With a link to this section: https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error

This is what I mentioned above, when you created you google maps API key you set a ‘referrer’ which tells Google which domains can use your key.

http://take.ms/017X9

I’m guessing yours is currently using *.improveucourses.com/*

Which means if the request comes from http://{anything}.improveucourses.com/ it will work.

Your domain is ‘naked’ meaning it has no ‘www’ or ‘.’ before the domain name. So your referrer should be: *improveucourses.com/*

If you update that within your google account for the api it should work correctly.

Make sense?


Alyssainmontana1

February 23, 2017 at 5:37 pm

THANK YOU!!! I went back to Google and added another “referrer” without it starting with the dot, and this totally solved the issue. And how you explained it makes perfect sense, although I would not have been able to figure this out on my own. What a relief! Thanks again!


Tony

  • Support Staff

February 24, 2017 at 3:55 am

You’re most welcome, I’m glad its working.

If you have any further problems please do let us know 🙂

The support post ‘This page didn't load Google Maps correctly…’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 years, 6 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!