Support

Home Forums Event Espresso Premium Stripe Payment Processing Not Working

Stripe Payment Processing Not Working

Posted: November 17, 2016 at 3:36 am


The InnBetween

November 17, 2016 at 3:36 am

The Stripe payment processing is not working on our site (www.innbetween.nl). Mollie payment seems to be working fine but it is just Stripe.

The Stripe completes and says payment is confirmed, after which EE also gives a message confirming payment. The user is then redirected to the transaction complete page where there is no transaction shown.

No transaction has been processed by stripe and there is no call to the API shown in the Stripe log. No transaction is shown in the WP admin panel. No error messages are shown in the console whatsoever.

I have refreshed the stripe access tokens and made sure they were correct. I have currently disabled Stripe to avoid any more confusion with users.

Thanks,
jacob


Josh

  • Support Staff

November 17, 2016 at 12:16 pm

Hi Jacob,

I checked the Thank You page on your website and there are a number of JavaScript errors being thrown. The first thing to do that may help is you can turn off the JavaScript magnification that’s set up with the W3 Total Cache plugin on your site.

The Stripe gateway uses Stripe.js and Event Espresso also uses its own JavaScript to update the payment info on that page. The JavaScript errors happening on that page may be preventing those scripts to run when they need to run.


The InnBetween

November 21, 2016 at 5:01 am

Hi,
Thanks for the response.

I have fixed all the errors in the console and reactivated stripe but still get the same problem.


Lorenzo Orlando Caum

  • Support Staff

November 21, 2016 at 1:21 pm

Hello,

Are any of the payment methods set to open by default through the payment methods screen?

If so, could you try turning that off please and saving changes to the payment methods?


Lorenzo


The InnBetween

November 22, 2016 at 5:29 am

Hi Lorenzo,
That seems to have worked! Both cash and stripe had the default payment set to true.

Is that specification in the docs? I didn’t see it before but might have missed it. It would have been helpful if I had seen a troubleshooting tip to turn off the default open payments.

Thanks,
Jacob


Josh

  • Support Staff

November 22, 2016 at 8:56 am

You should actually only have one payment method set to open by default, because only one payment method can be used in a transaction.

The support post ‘Stripe Payment Processing Not Working’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 2 years, 6 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!