Support

Home Forums Event Espresso Premium Split: Split: Stripe SCA Auth causing payment declined?

Split: Split: Stripe SCA Auth causing payment declined?

Posted: September 10, 2019 at 7:42 am


TARA

September 10, 2019 at 7:42 am

https://eventespresso.com/topic/split-stripe-sca-auth-causing-payment-declined/

I have the same issue as above and followed your advise but payments won’t work on my website. When I process and booking after I input my name and email address it shows the following text underneath the boxes for the above:
Card number
Expiry date (MM/YY)
CVC (Whats this/)
Please help?

  • This topic was modified 1 week, 2 days ago by  Tony.
  • This topic was modified 1 week, 2 days ago by  Tony. Reason: Split, adding link to original


TARA

September 10, 2019 at 7:43 am

PS. The test worked fine on debug mode but when I switched debug off what I described above happened. I have had to switch back to Stripe Checkout (Legacy)


Tony

  • Support Staff

September 10, 2019 at 8:31 am

Hi there,

My apologies but the text showing above looks like the labels for the fields so I’m not sure what that should be highlighting?

Can you re-enable Stripe elements and link us to a test event we can use to view the problem on, please?


Josh

  • Support Staff

September 10, 2019 at 8:35 am

Hi,

It sounds like your site isn’t connected to Stripe via the Connect API. If you go to the Event Espresso > Payment Methods > Stripe settings page, is there a “Connect with Stripe” button shown there? If so, you’ll click that button then follow the prompts to connect your site to use the Stripe API.


TARA

September 10, 2019 at 8:52 am

Hi Josh, I am connected to the Stripe API.

Tony, I have enabled Stripe elements again for you to look at a test event here https://www.meditateinireland.com/events/galway-the-healing-power-of-meditation/
Thank you.


Tony

  • Support Staff

September 10, 2019 at 8:55 am

Oh, I see now.

That does look like the connection not is set correctly.

Can you go to Event Espresso -> Payment methods -> Stripe.

Disconnect from Stripe, refresh the page and reconnect once again.

  • This reply was modified 1 week, 1 day ago by  Tony. Reason: not set correctly!


TARA

September 10, 2019 at 9:10 am

Done that now


TARA

September 10, 2019 at 9:11 am

Seems to be same issue!


Tony

  • Support Staff

September 10, 2019 at 9:21 am

All of the .JS and .CSS files on your site are being minified and combined.

Can you disable that so we can investigate? It looks like the Stripe elements JS from the add-on either isn’t loading or its wherever its loading is preventing it from running correctly.


TARA

September 10, 2019 at 9:29 am

This reply has been marked as private.


Josh

  • Support Staff

September 10, 2019 at 9:34 am

It’s not complicated to turn off caching. If you go to your site’s WordPress > Plugins page, you’ll find a plugin listed there that will say something about Caching and Minifying Javascript. You’ll go to that plugins settings page and look for an option that says “Rebuild Cache” or even “Deactivate Cache”.

Since we don’t manage your site and we don’t know exactly which plugins are installed there, the above instructions need to be a bit General purpose. If you can let us know exactly which plugin on your site adds the caching feature we can take a look at that plugin and advise further.


TARA

September 10, 2019 at 9:44 am

This reply has been marked as private.


Josh

  • Support Staff

September 10, 2019 at 10:38 am

No it wouldn’t be the Advanced Custom Fields plugin.

I’ll take a guess that the plugin is the W3 Total Cache plugin, and if that’s the plugin you have on your site, you’ll go to Performance>General settings > Minify and deactivate Minify, the save the changes to take affect.


TARA

September 10, 2019 at 10:49 am

This reply has been marked as private.


Josh

  • Support Staff

September 10, 2019 at 12:16 pm

OK thanks. While it didn’t solve the problem, it helped shed some light on what’s missing. What’s missing is a script that’s normally included if the site has WordPress version 5 or greater. With the caching turned off, I can more easily see that your site has WordPress version 4.9.

We’re going to try to include some changes in the next update to the Stripe add-on that will avoid requiring anything related to WordPress 5. So you could use Stripe Checkout in the meantime, or you could instead update to the current version of WordPress and then you’ll be able to use Stripe Elements.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Josh 1 week, 1 day ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!