Support

Home Forums Translations Some strings not translated although translated in the used .mo file

Some strings not translated although translated in the used .mo file

Posted: July 6, 2016 at 6:50 am


ARAGATO

July 6, 2016 at 6:50 am

I am localising my event espresso installation. I followed your translation guideline and everything worked. However, after successfully translating many strings I came across some strings that are not translated in the front-end although they are correctly translated in the .mo file that is being used.

It is on the single event details page in the section “more details”.
http://uploads.aragato-server.net/screenshots/20160706e99ce77a50.jpg
http://uploads.aragato-server.net/screenshots/201607061250e4d971.jpg
http://uploads.aragato-server.net/screenshots/201607069525b9f130.jpg


Lorenzo Orlando Caum

  • Support Staff

July 6, 2016 at 8:57 am

Hello,

I added one of those translation strings within our GlotPress project:

https://translate.eventespresso.com/projects/event-espresso-4/de/event-espresso-de_DE

Does it work as expected if you generate an MO file from GlotPress and then move that into place on your website?


Lorenzo


ARAGATO

July 6, 2016 at 10:10 am

Does not change anything.


ARAGATO

July 6, 2016 at 11:21 am

Again, many other strings translate perfectly. Its only these two that do not work.


Josh

  • Support Staff

July 6, 2016 at 1:56 pm

The strings for the ticket selector display are actually:

Total%sSold
and
Total Spaces%sLeft

https://translate.eventespresso.com/projects/event-espresso-4/de/event-espresso-de_DE?filters%5Bterm%5D=Total%25sSold&filters%5Buser_login%5D=&filters%5Bstatus%5D=current_or_waiting_or_fuzzy_or_untranslated&filter=Filter&sort%5Bby%5D=priority&sort%5Bhow%5D=desc

https://translate.eventespresso.com/projects/event-espresso-4/de/event-espresso-de_DE?filters%5Bterm%5D=Total+Spaces%25sLeft&filters%5Buser_login%5D=&filters%5Bstatus%5D=current_or_waiting_or_fuzzy_or_untranslated&filter=Filter&sort%5Bby%5D=priority&sort%5Bhow%5D=desc


ARAGATO

July 6, 2016 at 3:09 pm

Quality answer!
Working, thank you.

The support post ‘Some strings not translated although translated in the used .mo file’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  ARAGATO 4 years, 6 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!