Home Forums Event Espresso Premium "sold out" & Past Events – How Do You Hide Them?

"sold out" & Past Events – How Do You Hide Them?

Posted: June 22, 2017 at 2:48 pm


June 22, 2017 at 2:48 pm

Hey there.
Struggling a little bit with how to hide/remove events that occurred in the past from the registration page of the same event.

this URL is an example:

You’ll see that we’ve increased our price since the original class due to demand, but the old class has the lower price. The event is in the past, how do I hide it from the list?

I couldn’t find a wordpress page for this actual event to review the shortcodes, so maybe knowing where those are located would help too.



  • Support Staff

June 22, 2017 at 3:32 pm

Hi there,

You can set an option so those do not display. You go to Event Espresso > Events > Templates, then scroll down through the options there to almost the bottom of the page where you’ll see “Show Expired Tickets?” and you can set that to No and click on Save.


June 22, 2017 at 3:39 pm

Hi Josh,

I double checked those settings, and that is how it is currently configured. That is what I thought was odd, but figured it must be some other setting.

I also checked the date of the event to ensure that it wasnt posted in the future eventhough the event date was in May, and couldnt see an issue there either.

I have a screenshot, but don’t see an option to upload it.


  • Support Staff

June 22, 2017 at 3:54 pm

The setting may not have saved initially. Can you try setting Show Expired tickets to Yes, then save, then set it to No, then save again?


June 22, 2017 at 3:57 pm

Shoot! I was hoping it would be that easy.

I completed those steps and refreshed the event page. Still shows it. URL:
It was a class on May 21st. When I expand the details of that event it seems like it should meet the expired/past criteria.

Open to your other suggestions.

Thank you.


  • Support Staff

June 22, 2017 at 4:53 pm

I can investigate further about why that expired ticket is still displaying if you can complete the secure form on this page with some temporary access credentials.


June 22, 2017 at 5:04 pm

Josh – I’ve created a temporary account, but I can’t seem to find the secure form you referenced. Can you provide the link?


  • Support Staff

June 22, 2017 at 7:19 pm

Sorry about that, here’s the link:


  • Support Staff

June 22, 2017 at 7:37 pm

OK it’s all sorted now. The Show Expired Tickets setting was set to Yes. I changed the setting to No and the expired ticket is no longer displaying.


June 23, 2017 at 6:29 am

Thank you Josh! Was this a global setting, or a per event setting?

I see that it is resolved now, awesome! I just want to make sure I understand what I was doing incorrectly, to avoid having to bother you guys with a request like that again 🙂

I had toggled the yes/no on the main screen you indicated earlier in the thread, with no luck.


  • Support Staff

June 23, 2017 at 12:34 pm

It’s a global setting. I don’t know what happened when you tried changing the setting, maybe you didn’t click the save button after making the change?

The support post ‘"sold out" & Past Events – How Do You Hide Them?’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Josh 3 years ago ago

Topic Tags


This topic is: resolved
Do NOT follow this link or you will be banned from the site!