Home Forums Community Forum Proceed to Finalize Registration

Proceed to Finalize Registration

Posted: April 14, 2022 at 11:20 am

Grow Socially

April 14, 2022 at 11:20 am

I have been using Event Espresso for nearly 8 years with no major issues. Yesterday, we started to receive messages that when individuals complete the form for individual information at /event-registration/?uts=1649956309#checkout, it sends them to another page that is event-registration/?uts=1649956310&step=attendee_information#checkout that has another “Proceed to Finalize Registration” button. When clicked, it reloads that page.

I have tried disabling plugins, changing themes and even tried the Asset Clean-Up plugin, but nothing works. I am able to register if I log into the site as an admin. However, that only helps me, not those trying to register for events.


  • Support Staff

April 14, 2022 at 4:20 pm

Hi there,

So, just to explain the UTS value a little, it’s nothing more than a timestamp we add to the URL as a cache-busting method. It stands for Unix TimeStamp and is the number of seconds passed since Jan 01 1970, see here:

?uts=1122334455 is not a ‘valid’ value that EE would ever actually generate but will still allow things to work normally because thats the intention, its just a random value added to prevent some forms of caching 🙂

The issue here is from the ReCaptcha, being logged into the site and have it working points to 2 issues.

1. Caching.
Logged in users aren’t usually served cached responses, they skip the cache and so if it works when logged in but not logged out, its often a caching issue. (Doesn’t appear to be on your site)

2. ReCaptcha.
Again, within Event Espresso itself, ReCpatcha is disabled when logged into the site, meaning if it works when logged in but not when logged out it can point to an issue with reCaptcha.

This is what appear to be the issue on your site, it looks like you are using the Checkbox reCaptcha method and what has mostly likely happen is your host has updated PHP and now has allow_url_fopen disabled on the server. That function is required for the checkbox recaptcha to function and when disabled it gives the issue you explain above (I’ve also tested a registration and have see the issue myself).

You can either… enable allow_url_fopen on the server again (your host will often have options for this or you can contact them and request they do it for you). This would be my recommend method as the invoices/receipt PDF’s also uses that function.

Or switch to using the Invisible recaptcha which does not require allow_url_fopen to be enabled to work.

Grow Socially

April 15, 2022 at 7:28 am

Thank you for assisting me. Your fix did the trick.


  • Support Staff

April 19, 2022 at 4:22 am

You’re most welcome, I’m glad it worked 🙂

The support post ‘Proceed to Finalize Registration’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso