Support

Home Forums Translations Problem setting French language EE4

Problem setting French language EE4

Posted: January 17, 2017 at 2:47 am


alexander

January 17, 2017 at 2:47 am

Hello,
I have set up EE4 on our website to manage training events and I started with EE Decaf. After having bought a License Key in December, I have set-up the French language files .po and .mo as explained in our guide on how-to translate EE.
However, this does not seem to work on all parts of EE.

I have read a few other posts on the support forum related to this question but have not found any answers to my problem. I have noticed though that my wp-content/plug-ins/ contains event-espresso-decaf and not event-espresso-core-reg. Would that be a cause ?

Thank you for your answer.


Tony

  • Support Staff

January 17, 2017 at 3:46 am

Hi there,

It shouldn’t be no.

Lets start by confirming which version of Event Espresso you currently have installed and activated on the site.

If you go to Dashboard -> Plugins.

Look within the list and find Event Espresso, does it show Decaf there or does it look like this – http://take.ms/Me2N6v


alexander

January 17, 2017 at 6:21 am

Hello Tony,
Thanks for your reply,
I am running EE 4.9.25.p with the following add-ons :
Event Espresso – Calendar 3.2.7p
Event Espresso – Events Table View Template 1.3.5.p
Event Espresso – Grid View Template 1.2.3.p (although not implemented yet)


Tony

  • Support Staff

January 17, 2017 at 6:54 am

That’s the full version of Event Espresso.

Is Decaf also listed in the list of plugins but not activated? (don’t activate them together)

Can you let me know which parts are not translating?


alexander

January 17, 2017 at 7:24 am

Decaf is not listed in my plug-ins (I deleted all previous EE test on our website before installing the full version)

Parts that are not translated included :

  • most menus of the dash board
  • some headers of lists (as the event lists)
  • on an event page
  • registration check out page

I have checked the translations on GlotPress and they seem to have already been validated.
I worked on a number of translations on GlotPress, could they be validated ?


Tony

  • Support Staff

January 17, 2017 at 9:33 am

It sounds like the translation file is not loading.

Whats the full filename for the MO and PO files your have?

Also what location are the stored within currently?


alexander

January 18, 2017 at 2:23 am

That is what is it seems like :
here are the file names :
event_espresso-fr_FR.mo and event_espresso-fr_FR.po

and the path to their location :
/wp-content/uploads/espresso/languages

My EE directory is :
/wp-content/plugins/event-espresso-decaf


Tony

  • Support Staff

January 18, 2017 at 5:33 am

The file name looks correct.

However I’m not sure why you have the event-espresso-decaf directory name, have you modified EE at all? (Not including translations)

One way to fix that is to de-activate and delete the current version of Event Espresso you have installed on the site (no event data will be lost)

Download the latest version from your account page and upload that to your site through Dashboard -> Plugins -> Add new -> Upload plugin.

You will need to fix the image urls within your Receipt template after doing this:

Event Espresso -> Messages -> Default Message templates -> Receipt.

If you have not modified the template previously just click the ‘reset templates’ button and EE will rebuild the template for you using the correct file path.

You’ll then know for sure you are using the latest version.

I’m assuming you have your site language in Dashboard -> Settings set to French and are not using a multi language plugin?


alexander

January 20, 2017 at 1:57 am

Good morning,
It seemed we had a problem with our website as a whole so after a backup was applied, all works fine now.
We were able to send out the registrations for our training courses on-time.

I have noticed that some translations are a incorrect (i.e. Venues -> Stades…) so I will continue my work on translation via GlotPress.

Thank you for the support.

Alexander


Tony

  • Support Staff

January 20, 2017 at 4:40 am

Great, I’m glad you found the problem 🙂

The support post ‘Problem setting French language EE4’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!
[i]
[i]