Support

Home Forums Event Espresso Premium need a "code snippet" and "event ID"

need a "code snippet" and "event ID"

Posted: April 30, 2023 at 11:23 pm


markolson68

April 30, 2023 at 11:23 pm

I’ve been using EE for the last year and haven’t had any problems with it until this week. I don’t even know if I’m having a problem with EE specifically. All I know is that no one can register for my events anymore because all payments are being declined. I get a network error and a message to contact Stripe. I contacted Stripe and they sent me to my hosting company, who after much effort figured out that none of the events were registering on their server and that Stripe was rate limiting traffic from all of their servers. When I told this to Stripe, they just ignored what I said and insisted that I “contact my developer” (which is me, sorta, since I installed EE) and that I send them a “code snippet” and an “event ID”. I have no idea what they are referring to or how I would provide this, and I don’t get why they need anything from EE since my host made it very clear that this has nothing to do with EE. But anyway, Stripe insists, and I assume they are asking for something EE related. Any ideas?


markolson68

May 1, 2023 at 1:08 am

I have not installed any “code snippets”. I just use EE as it is. I have no idea if event ID refers to the ID of the EE event or a transaction ID. Stripe is not forthcoming in helping me understand what they need.


Tony

  • Support Staff

May 1, 2023 at 1:04 pm

Hi there,

This does indeed sound like an issue with communication between your server and Stripe currently. I’m not really sure what Stripe is referring to by code snippet or Event ID.

I suspect they are not asking for an EE Event ID but a Stripe API event ID so they can view the request, however, if every transaction is failing I would have assumed they could have just pulled this in via your account anyway.

If you view the EE Transaction for one of those transactions can you see anything in the ‘gateway response’ field for the Stripe payment?


LSCS

May 3, 2023 at 9:21 am

I am having the same issue. I upgraded to EE 5.03 in the last week. No transaction records are being created. The user just sees a message saying ‘An invalid response was returned from the server while attempting to process your request’.
I’m working my way through this, but it seems EE is not capturing any registration info about the contact


Tony

  • Support Staff

May 3, 2023 at 1:04 pm

Hi there,

That sounds like a different issue.

Is that happening at the end when the user tries to pay via the Stripe payment method or on the Attendee Information section?

Can you link me to an event I can register onto to test?


markolson68

May 10, 2023 at 10:21 pm

This issue turned out to have nothing to do with EE. AWS was blocking all traffic from the shared server I was on, which made it appear to my webhosting that Stripe was rate limiting traffic from the server. I solved it by getting a private server.


LSCS

May 11, 2023 at 9:31 am

Regarding my issue, I found on another thread that someone was experiencing something similar. After going into safe mode, and disabling plugins, he found that the facebook pixel plugin was the root. I deactivated it and this fixed the issue.

This issue has highlighted the ghost registrations. At the time these pointed to errors. Now I don’t know if subsequent ghost entries are issues, or simply users leaving the registration page before submitting details. Anyway to find out?

The support post ‘need a "code snippet" and "event ID"’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso