Support

Home Forums Event Espresso Premium FPDF error

FPDF error

Posted: July 20, 2017 at 8:22 pm


thinkbiglearnsmart

July 20, 2017 at 8:22 pm

We’re on EE3 and are getting the following message when downloading PDF invoices: FPDF error: Missing or incorrect image file: http://thinkbiglearnsmart.com/wp-content/uploads/2017/07/tblogo2.jpg

This started happening after a server update to Easy Apache and PHP 5.6.

I’ve ensured that allow_url_fopen = ON in the php.ini.

I’ve tried setting image_default_link_type to ‘file’, but when I save that change it doesn’t take, though I don’t get any errors.

Event Espresso version 3.1.37.11.P
WordPress version WP 4.7.5


Josh

  • Support Staff

July 21, 2017 at 8:02 am

Can you try setting the logo option to:

http://www.thinkbiglearnsmart.com/wp-content/uploads/2017/07/tblogo2.jpg


thinkbiglearnsmart

July 24, 2017 at 5:41 pm

That’s what the logo was set to. We’ve tried both https and http.


Josh

  • Support Staff

July 25, 2017 at 8:21 am

So the url in the settings page has the www but the error message doesn’t include the www? Do you have any redirections set up that remove the www?


thinkbiglearnsmart

July 25, 2017 at 8:41 am

Oh, I see. I tried with the ‘www’ and got the same error. I believe we do have settings to redirect to no ‘www’ for all pages.


Josh

  • Support Staff

July 25, 2017 at 8:51 am

The redirect may be causing the issue. The simple solution in this case may be to host the image from a different server.

The support post ‘FPDF error’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 2 years, 3 months ago ago

Topic Tags

Tagged: , ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.