Support

Home Forums Community Forum Error when Confirming Reg: espresso/gateways/gateway_display.php on line 48

Error when Confirming Reg: espresso/gateways/gateway_display.php on line 48

Posted: December 8, 2016 at 4:19 pm


pvangorder

December 8, 2016 at 4:19 pm

Your registration is not complete until payment is received.
Amount due: $159.00
Your Registration ID: 5849e549197805.66735139
A confirmation email has been sent with additional details of your registration.

Warning: require_once(/home/content/85/8132085/html/wp2/wp-content/uploads/espresso/gateways/paypal/init.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/85/8132085/html/wp2/wp-content/uploads/espresso/gateways/gateway_display.php on line 48

Fatal error: require_once() [function.require]: Failed opening required ‘/home/content/85/8132085/html/wp2/wp-content/uploads/espresso/gateways/paypal/init.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/content/85/8132085/html/wp2/wp-content/uploads/espresso/gateways/gateway_display.php on line 48


pvangorder

December 8, 2016 at 4:21 pm

I’ve tried turning off all plugins (except EE plugins) and using a simple default theme.
Nothing helped.


Josh

  • Support Staff

December 8, 2016 at 5:08 pm

The error messages indicate that someone went in and emptied the files in /wp-content/uploads/espresso/gateways. So you’ll either need to completely delete those files or restore what was there before.


pvangorder

December 8, 2016 at 5:30 pm

No, all those files are still there:

gateway_display.php
payment_gateways.php
PaymentGateway.php
process_payments.php

check (folder) ->
check_ipn.php
check_payment_vars.php
index.php
init.php
settings.php


pvangorder

December 8, 2016 at 5:31 pm

The last thing I did was update wordpress to the latest version.


Josh

  • Support Staff

December 8, 2016 at 5:48 pm

No, all the files are not there. You may have some, but not all. Here’s that error message again:

Fatal error: require_once() [function.require]: Failed opening required ‘/*redacted*/wp-content/uploads/espresso/gateways/paypal/init.php`

So it’s looking for a PayPal folder there in the /wp-content/uploads/espresso/gateways folder, but apparently there is no PayPal folder there.


pvangorder

December 8, 2016 at 5:53 pm

My Bad – I thought they were all there because I was comparing them to a backed up version. But apparently that backed up version had them removed too. Perhaps when SiteLock scanned for malware it deleted them??

In any case – WHERE do I get them? So I can upload them to that folder?

Thanks SO much!


Josh

  • Support Staff

December 8, 2016 at 6:28 pm

from the wp-content/plugins/event-espresso/gateways folder


pvangorder

December 8, 2016 at 6:46 pm

Well, I wasn’t able to get them from :
The “wp-content/plugins/event-espresso/gateways” folder, because for some reason, as I said, SiteLock or something must have removed them. But I was able to find the files the original purchase folder.
Anyways, I got it working with your help so….

THANKS!!!!!!!


Josh

  • Support Staff

December 8, 2016 at 6:50 pm

You might consider reinstalling the Event Espresso plugin files from a copy of your original folder because there might be a few other missing files.

The support post ‘Error when Confirming Reg: espresso/gateways/gateway_display.php on line 48’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

If you would like help from the Event Espresso staff, then please purchase a support license right now so you can create a support topic in our premium support forums.

Status: closed

Updated by  Josh 2 years, 10 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!