Support

Home Forums Event Espresso Premium Email notifications not working to customer or internal

Email notifications not working to customer or internal

Posted: September 22, 2017 at 10:48 pm


rhumphrey

September 22, 2017 at 10:48 pm

hi guys, i am currently using the default message templates but for some reason, neither the customer or the internal staff are receiving any of the notifications. Any advice or guidance you can give on the setup for this please is much appreciated.

thanks


Tony

  • Support Staff

September 25, 2017 at 3:33 am

Hi there,

Do other emails work from the site, such as ‘password reset’ emails? You can test using the Check Email plugin to send a test email from your site.

If you go to Event Espresso -> Messages, do you see a list of messages there?

If so what colour ‘status bar’ do the messages have (the coloured bar on the left of each message)?

Also if you go to Event Espresso -> Messages -> Settings

You’ll find the option ‘On a separate request’, what is that set to?


rhumphrey

September 25, 2017 at 7:07 am

HI tony, thanks for getting back to me. i have checked emails are working i have a number of contact forms on my site and all seem to work perfectly well, for example the customer and the notification to internal staff is received.

As for your questions

i see one message in there and it is green, but we never received the email notification from this, and we can cannot confirm the user did either.

under messages and settings this is set to forever and on a separate request.

i have completed tests using both payment methods, i have invoice and paypal setup, but receive no notification of any process or transaction.

any help you can offer is greatly appreciated.


Josh

  • Support Staff

September 25, 2017 at 10:04 am

You can try setting the option to send on the same request. Your server might not be able to support sending messages on separate requests.


rhumphrey

September 25, 2017 at 7:29 pm

i have changed the settings to your suggestion and that works which is awesome, one small problem though the internal notification email i have setup is not going to the correct address, for exampple marketing@ but should be going to info@. i have been through the entire site to see where this is being picked up from and cant find any reference to marketing@..

any advice please.

thanks


Tony

  • Support Staff

September 26, 2017 at 1:48 am

The ‘internal notification email’, as in the Event Admin email? If so EE is using the user account details for the user set as the author of the event -http://take.ms/lOPPs

You can change the shortcode used on the event admin emails if preferred, for example if you wanted to use the ‘Primary Contact Email’ set in Event Espresso -> General Settings you can change the above shortcode to be [CO_EMAIL]


rhumphrey

September 26, 2017 at 7:40 pm

sorry tony, i cant open your link, i guess you trying to show me an image, i have been into the the general settings section and the primary email is set as info@. which is the address i want it to use. can you show me where you want me to place the shortcode again please.

thanks


Tony

  • Support Staff

September 27, 2017 at 3:49 am

My apologies looks like I missed a character – http://take.ms/lOPPs3
(I’ve also edited my reply above to include the correct link)

All of the ‘Event Admin’ emails use the event author, so you’ll need to change all of them to use the [CO_EMAIL] shortcode – http://take.ms/YRDmN

Any message type that has a blue ‘Event Admin’ link has that context active so and will need to be edited by clicking on that link and changing the shortcode shown in my screenshot.

The support post ‘Email notifications not working to customer or internal’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 years, 2 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!