Support

Home Forums Event Espresso Premium EE4 Registrations Fail Then Success with Authorize.net

EE4 Registrations Fail Then Success with Authorize.net

Posted: February 5, 2018 at 8:55 pm


CWAG

February 5, 2018 at 8:55 pm

Hello,

We just upgraded to EE4 recently and are having issues when people register. Someone just tried to register, but after paying, the site said to her that payment was unsuccessful. Then it went through and was successful. Same thing happened to me last night when I tested it with my $1 payment. Let me know when I should do.


CWAG

February 5, 2018 at 9:05 pm

Further registrant feedback:

“Thank you so much. I did register 3 under my name. the website showed an issue with the payment going through but I shows up on my account. If for some reason it does not go through, Please let me know, But I was unable to get past the payment page.”

“then two minutes later, she said she got a confirmation email saying it did go through.”

Let me know what I should do.


Tony

  • Support Staff

February 6, 2018 at 4:19 am

Hi there,

Do you have a screenshot of the error being thrown?

The response shown straight after a payment is usually directly from the payment provider (in this case that would be auth.net).

Which payment method are you using with them? SIM or AIM?


CWAG

February 7, 2018 at 9:51 pm

We don’t have a screenshot, just multiple reports from people you register. Also, we are using the AIM method.


Tony

  • Support Staff

February 8, 2018 at 3:37 am

Ok, if you view the transaction for one of the registrations that had an error (your test one is fine) do you see an error in the gateway response section?

To find that you go to Event Espresso -> Registrations.

Find the registration in the list and click on the TXN Date – http://take.ms/Qfdo6

Then you’ll see something like this – http://take.ms/obcVB

If not, go to Event Espresso -> Payment methods -> logs

Each AIM payment will create at least 3 log entries.

If you click on the ID of the log entry (not the TXN ID) you’ll open up the log entry, look for one that has ‘AIM Response received:’ then check the ‘error’ and ‘error_message’ sections of that log entry.

Any errors shown there?


CWAG

February 8, 2018 at 4:28 pm

Yes, here is what shows. The transactions will fail and then they will process successfully: https://www.dropbox.com/s/xiur75wajw7nhlb/Screen%20Shot%202018-02-08%20at%203.24.39%20PM.png?dl=0

These transactions are also marked as “pending” in EE4. Registrants will also receive emails saying the payment is pending even though they have been charged in some cases.

– Nick W.


Tony

  • Support Staff

February 9, 2018 at 3:31 am

That transaction has 2 payments, the first was declined by the user’s bank/merchant service, the second went through.

The first payment shows ‘Reason code 2’ which is – ‘General decline by card issuing bank or by Merchant Service Provider’

See here: https://support.authorize.net/authkb/index?page=content&id=A50

The error is directly from Auth.net meaning you would need to contact them for more details on that specific payment.

Can I take a quick look at your payment logs in the admin? I’ll check if anythign stands although likely not with that error.

If so you can send temporary login details using this form:

https://eventespresso.com/send-login-details/

The support post ‘EE4 Registrations Fail Then Success with Authorize.net’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 8 months, 1 week ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!