Support

Home Forums Event Espresso Premium Edit Message Shortcode

Edit Message Shortcode

Posted: August 4, 2020 at 5:54 pm


JohnB

August 4, 2020 at 5:54 pm

Hi guys,
In a message template there is a shortcode [CO_FACEBOOK_URL] and [CO_GOOGLE_URL]. The actual link in the message is not active because I’m guessing the actual url has not been set up somewhere. (the FB url is recorded in the “social links” section / general settings)
Where do I edit the settings for shortcodes such as these ie record the actual url
Thank you


Tony

  • Support Staff

August 5, 2020 at 7:41 am

Hi there

When you say it’s not active, is the value being pulled through it’s just no clickable or is nothing being shown?

Can you link me to an event I can run a test registration on so I can view the email? Or forward the email onto support[at]eventespresso.com so I can take a look at it?

To answer your question, the values for CO_FACEBOOK_URL and CO_GOOGLE_URL are from:

Event Espresso -> General Settings -> Your Organization -> Social Links

Which it sounds like you’ve already set, right?


JohnB

August 5, 2020 at 3:54 pm

Thanks,
When I look at the preview the images are there but in the actual email, those images are not there. Sent sample to you.

In the General Settings / Your OrganiSation, Social Links – there is provisions for Facebook, Twitter, LinkedIn, PinInterest, Instagram No provision got Google+

I will try to send you a smaple


Tony

  • Support Staff

August 6, 2020 at 9:08 am

The only way I can think of that happening is if you are using the wrong ‘context’ for the emails.

Each message type has multiple ‘contexts’ in which it can be used, to put that into your example, the ‘Refund Issued’ message type has an ‘Event Admin’ and ‘Primary Registrant’ context. You can see those here:

https://monosnap.com/file/oynz54KU4uSLv4KKspuni8itpXj2jq

On my site (and by default within EE) the ‘Event Admin’ context is disabled (shown in grey), what does it show on your site?

For more info on message contexts take a look here:

https://eventespresso.com/wiki/messages-system-working-with-message-contexts/


JohnB

August 6, 2020 at 4:32 pm

Tony,
The version of the email I receive (when using “test send” for the “primary recipients” version shows blank space under the heading “Connect With Us”.
I have resent the message to you. Can you confirm if you are seeing the same.

Also where do I record our Google+ details? (see original post)

Thank you


Tony

  • Support Staff

August 7, 2020 at 2:59 am

I have resent the message to you. Can you confirm if you are seeing the same.

No, I see the Connect with us section with the buttons:

https://monosnap.com/file/IOsSJnhRVO22Frpn5tANnA5rR3VaaL

However, the layout is ‘broken’ as that section should be centred and look slightly different, I’m guessing you’ve edited the template?

Also where do I record our Google+ details? (see original post)

Google+ shutdown April 2, 2019 so we removed it from Event Espresso. Message templates that already have it saved in the DB (like yours) will still show it but it can be removed.

Have you customized the template at all? If no you can use the message template reset function (in the sidebar of each message template type below the test send) to ‘reset’ your templates to the current defaults.

Note – using that button resets the templates for all ‘contexts’ of the message type you click it on and you will lost any changes made to the template you click it on.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 1 month, 3 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!