Support

Home Forums Translations Custom dutch translations not working

Custom dutch translations not working

Posted: July 19, 2016 at 3:33 am


pvhaganees

July 19, 2016 at 3:33 am

Hi there,

I have been trying to translate different parts of EE4 in my installation but without luck. First I have tried to do the translations with loco translate but the changes did not show up in the frontend. Then I downloaded the translation from GlotPress and edited them in POEdit as you suggested. Afterwards I uploaded the files to wp-content/uploads/espresso/languages/ but they don’t show up in the frontend. The filenames are event-espresso-4-nl.mo and .po

As I looked at the file structure I also tried uploading the files to wp-content/uploads/event-espresso-core-reg/languages/ but also no luck there…

Can you tell what I am doing wrong? If you need credentials to my installation, please let me know.

Greetings Paul


pvhaganees

July 19, 2016 at 4:00 am

Never mind…I saw that the name of the files should be changed to event_espresso-nl_NL.po and .mo

Now it works finally.

Still I do not understand why Loco translate does not work…


Tony

  • Support Staff

July 19, 2016 at 4:06 am

Hi there,

The filenames are event-espresso-4-nl.mo and .po

That’s not the correct file not to be picked up by EE.

You need event-espresso-{locale}.mo so you in your case it would be:

event-espresso-nl_NL.mo

(You can also use the event-espresso-4-{locale}.mo filename, the ‘-4-‘ is just another filename that EE will check for, but the full locale is important)

We have some documentation on translating Event Espresso here:

https://eventespresso.com/wiki/how-to-translate-event-espresso/

The support post ‘Custom dutch translations not working’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Tony 4 years, 6 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!