Support

Home Forums Event Espresso Premium Critical Error on Website due to EE plugin update

Critical Error on Website due to EE plugin update

Posted: November 18, 2021 at 4:25 pm


zimei.com.au

November 18, 2021 at 4:25 pm

I have logged this error 15 hours ago – it has crashed my website – assistance please


Seth Shoultes

  • Support Staff

November 18, 2021 at 4:33 pm

Hi there,

We are working on releasing an update to fix the issue right now. It should be available soon (an hour or two).


Tony

  • Support Staff

November 18, 2021 at 4:34 pm

Hi there,

Which error did you log?

We have just pushed v4.10.17.p live, could you please update to that version and confirm if this still happens?

If you don’t see the update available in Dashboard -> Plugins for Event Espresso then go to:

Event Espresso -> General Settings.

Don’t make any changes and just hit save to force a version check.

It should then show the update available.


zimei.com.au

November 18, 2021 at 4:38 pm

I cant access my website at all – the website reads

Fatal error: Uncaught TypeError: Argument 1 passed to EventEspresso\core\services\request\CurrentPage::__construct() must be an instance of EE_CPT_Strategy, null given in /home/zimei/public_html/wp-content/plugins/event-espresso-core-reg/core/services/request/CurrentPage.php:68 Stack trace: #0 [internal function]: EventEspresso\core\services\request\CurrentPage->__construct(NULL, Object(EventEspresso\core\services\request\Request)) #1 /home/zimei/public_html/wp-content/plugins/event-espresso-core-reg/core/EE_Registry.core.php(1275): ReflectionClass->newInstanceArgs(Array) #2 /home/zimei/public_html/wp-content/plugins/event-espresso-core-reg/core/EE_Registry.core.php(784): EE_Registry->_create_object(‘EventEspresso\\c…’, Array, ”, false) #3 /home/zimei/public_html/wp-content/plugins/event-espresso-core-reg/core/services/loaders/CoreLoader.php(116): EE_Registry->create(‘EventEspresso\\c…’, Array, true, false, false, ”) #4 /home/zimei/public_html/wp-content/plugins/event-espresso-core-reg/core/services/loaders/CachingL in /home/zimei/public_html/wp-content/plugins/event-espresso-core-reg/core/services/request/CurrentPage.php on line 68


Tony

  • Support Staff

November 18, 2021 at 4:49 pm

Hmm, strange.

So either there’s is a plugin conflict or WordPress failed to update the Event Espresso plugin files correctly and now you have missing files.

Do you have FTP credentials?

I’ll take a look at this if you can send them over using this form:

https://eventespresso.com/send-login-details/


zimei.com.au

November 18, 2021 at 5:06 pm

in recovery mode – Version 4.10.16.p – i cant seem to update to the newer version


Tony

  • Support Staff

November 18, 2021 at 5:09 pm

Yeah you’ll need FTP access to fix this, or some form of File Manager if you host has one?


zimei.com.au

November 18, 2021 at 5:10 pm

Not sure re FTP credentials – use cPanel


Tony

  • Support Staff

November 18, 2021 at 5:19 pm

With cPanel you have the option for either.

On the main page will be ‘File Manager’, the problem is I can’t direct you on exactly where to go from there as it depends on how your host is set up.

Usually file manager will open up root, so your looking for either a /public_html directory and then /wp-content/plugins/ to find a list of all plugin directories on your site.

Find the event-espresso-core-reg directory and just rename it to anything, I recommend just adding -temp to the end.

That will deactivate Event Espresso on your site and get you back into the admin.


FTP (If you prefer for me to fix this)

You’ll also usually have the option to create FTP accounts through cPanel.

On the cPanel main page you’ll see ‘FTP Accounts’

The ‘login’ is the username, it can be whatever you want.

Set the domain to be the correct site (if it allows you to set it)

Set a strong password (make sure you note it down so you can send it over)

In the ‘directory’ section, make sure whatever you can set it empty, that gives the account access to everything.

Create the account and send me the details you just used on the forum again.

I’ll use those to find the directory I mentioned above.


zimei.com.au

November 18, 2021 at 5:30 pm

i think i have created a FTP account and sent to you via form


Tony

  • Support Staff

November 18, 2021 at 5:48 pm

Almost, looks like you created an account with access to a specific directory so all I have access to is an empty directory.

Edit the account and make sure the directory section is empty:

https://monosnap.com/file/PlEjtwrIs8d8A4uT7PIlqwuIjOdlcP


zimei.com.au

November 18, 2021 at 8:44 pm

This reply has been marked as private.


zimei.com.au

November 21, 2021 at 8:39 pm

This reply has been marked as private.


zimei.com.au

November 22, 2021 at 8:05 pm

This reply has been marked as private.


Tony

  • Support Staff

November 23, 2021 at 9:35 am

Hi there,

Apologies for the delayed reply, we’ve been working on a couple of issues along with your trying to narrow down the cause. I switched your site back over to 4.10.13.p so that you site was at back up and running whilst we investigated further and worked through the code.

Currently, I can’t reproduce this locally, I’ve tried with all of the same plugins I can test with but still no fatal.

I’d like to add some additional debugging code to your site and switch back to the newer version again to see if that helps narrow it down some.

Just checking if that’s ok?

(Note I’ll switch the site back to 4.10.13.p again when finished to keep it up for the time being)

Does this mean I can no longer update EE?

Right now, yes, but we are investigating the cause to hopefully find a fix. It’s difficult to troubleshoot without reproducing locally.


zimei.com.au

November 23, 2021 at 6:51 pm

This reply has been marked as private.


Tony

  • Support Staff

November 24, 2021 at 6:55 am

Hi Leisha,

We spent some time digging into this had managed to reproduce the problem and find the cause.

It’s the version of PHP currently installed on the server causing this.

Your server is currently running PHP7.0.33, that version of PHP has been end of life (eol) since Jan 2019 and I highly recommend the server is updated to use a newer version.

So I recommend contacting your host and have them update the version of PHP in use on the server to PHP7.4 (at the time of writing the latest is 7.4.26). Once they’ve updated PHP you should then be able to update Event Espresso without issue.

Note – the highest version of PHP is currently PHP8, however, I do not recommend using it right now as it has a lot of ‘breaking’ changes for code that was previously perfectly valid, so a lot of plugins (including Event Espresso) are not fully compatible with it yet.

Currently, there are a few versions of Event Espresso installed on your site and I recommend removing all of them except the currently active 4.10.13.p version, then once the version of PHP has been updated simply update that version of EE.

You must be logged in to reply to this support post. Sign In or Register for an Account

Event Espresso