Support

Home Forums Event Espresso Premium Worldpay thank you page not displaying correctly

Worldpay thank you page not displaying correctly

Posted: September 27, 2012 at 7:53 am


sgrunsell

September 27, 2012 at 7:53 am

Ok so ee is configured to display the tahnk you page after the transaction in worldpay. This displays correctly in Firefox and safari but in IE and chrome it wont load in the style sheets and only displays the raw html.

In chrome it says:

enter image description here

in ie:

enter image description here

Please help!


Dean

September 27, 2012 at 11:56 pm

I get this all the time. I think you have recently upgraded Norton Internet Security. Notice the Shield in the address bar? It’s basically blocking the css and some other stuff because it thinks its not secure when 99% its fine. Clicking the shield should give an option to display your content, but it may be worth checking your settings.


sgrunsell

September 28, 2012 at 2:40 am

Hi dean, Thanks for the response.

I dont actually have norton, although I do have nod32. Are you saying theres nothing I can do about it and have to rely on the user to be ok with it? It just doesn’t look very good and I think my clients will have a problem with this.

cheers chris


Dean

September 28, 2012 at 4:00 am

Hi Chris,

It looked like the same issue I get with Norton on sites (I’ve had it happen on well known sites too).

I will happily run this by the devs to see if they can find out how we can get around the issue of the page having secure and insecure content, and whether it is purely related to EE, or whether its a general HTTPS issue.

I or a dev will get back to you on this.


sgrunsell

September 28, 2012 at 4:10 am

Hi dean

Great please do that, thanks.

chris


Sidney Harrell

September 28, 2012 at 7:43 am

Do you have an ssl cert for your site? Can you try the “Force https on return” option in the payment settings? That may force the css and scripts to be loaded via https.


sgrunsell

September 28, 2012 at 7:50 am

Hi Sidney

No, no ssl cert for the site. I have tried with and without that checked, makes no diff. Also have the Event Espresso – SSL/HTTPS plugin installed if that makes any difference.

cheers chris


Sidney Harrell

September 28, 2012 at 12:57 pm

Yeah, you’re going to need an ssl cert in order for any of that to work. You can get a free one from https://www.startssl.com/?app=1

The support post ‘Worldpay thank you page not displaying correctly’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!