Support

Home Forums Event Espresso Premium Widget not showing information

Widget not showing information

Posted: September 3, 2012 at 8:40 pm


Alastair

September 3, 2012 at 8:40 pm

Hi team,
The Event Espresso Widget is not showing my upcoming Events. It is showing the title “Upcoming Events,” but thats it. It has been fine, but I think it disappeared after I updated my Pagelines framework. The Calender is showing upcoming events.
http://www.cityathletenyc.com

Any suggestions would be appreciated!
Thanks,
Alastair


Jonathan Wilson

September 3, 2012 at 10:20 pm

Hello,

I looked at your site and could not find the issue. Did you resolve it?


Alastair

September 4, 2012 at 6:13 pm

Jonathan, thanks so much for the note. The Widget sits in the Primary Sidebar and should display upcoming classes, which there are 3 over the next week, but I just see the title “Upcoming Classes” and that’s it. Do you see the dates and times of classes also?
http://city-athlete.com/testing-leader-board/

Thanks! Alastair


Sidney Harrell

September 4, 2012 at 6:29 pm

If they are recurring events, make sure you select “show recurring events” in the widget options.


Alastair

September 4, 2012 at 6:40 pm

Yes they are Sidney, and I have that as a “Yes” in the Widget controls.


Sidney Harrell

September 4, 2012 at 6:45 pm

Can you uncomment the debugging line in templates/widget.php line 72:

print_r($events);

Can you set WP_DEBUG to true in wp_config.php and see if the widget is throwing a warning?


Alastair

September 4, 2012 at 6:57 pm

I’m sorry Sidney, I’m a little lost with that. Can you give me a step by step?


Jonathan Wilson

September 4, 2012 at 8:46 pm

Do you have ftp access to your WordPress install and the plugin files?

If so, you need to access the widget.php file which is located in your templates directory: wp-content/plugins/event-espresso/templates/widgets.php

When you find the file, open it with a text editor, like Notepad. On line 72 of that file, you will see //print_r($events);. Remove the dashes in front, so it looks like this print_r($events);, and save the file.

Setting WP_DEBUG:
You will find wp-config.php in wordpress directory. On line 82 (for me. could be different for you), you will find define('WP_DEBUG', false); change it to define('WP_DEBUG', true); and save the file.


Alastair

September 4, 2012 at 9:41 pm

Ok, I’ve done the first half of this, now with the WordPress directory, is it still ftp access?


Jonathan Wilson

September 4, 2012 at 10:23 pm

Yes. If you are logged into your ftp client, you will find the wp-config.php.

The support post ‘Widget not showing information’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Jonathan Wilson 7 years, 2 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.