Support

Home Forums Event Espresso Premium Warning Message Preventing Sales

Warning Message Preventing Sales

Posted: December 30, 2013 at 7:55 am


BurntCorkMedia

December 30, 2013 at 7:55 am

Lucky me, on the worse possible day, I find that all of my transactions are not able to go through and I have the following warning in my payment settings showing. Appreciate your help!

Warning: file_get_contents(

  • This topic was modified 6 years, 8 months ago by  Josh.


BurntCorkMedia

December 30, 2013 at 7:57 am

PS: Not done myself any favours there re link. Can I get this edited out for security? Ta! πŸ™‚


Josh

  • Support Staff

December 30, 2013 at 10:53 am

Hi Marcia,

Unless you are using the ATOS gateway the warning message that you are seeing will not affect the payments process. Can you let us know which payment method is in use on this site so we can investigate further?

It will also help to know if at one point the payments were working before, and a link to the registration page will help too.


BurntCorkMedia

January 2, 2014 at 5:57 am

Thanks for your swift response Josh. I am using Paypal Pro and Paypal. Paypal Pro requires 3D security. When I was using woo-commerce (prior to event expresso) it allowed me to add in 3D security details to the site. This is obvious not the case here. Unfortunately (or fortunately!) the warning sign is no longer showing (it had appeared on the payment settings page if I recall correctly). I would be grateful if you could advise how I would implement the 3D security as outline above.

Many thanks


Josh

  • Support Staff

January 2, 2014 at 2:20 pm

Hi there,

I’m sorry. At this time Event Espresso does not have support for 3d secure but we can submit a feature request so that the PayPal Pro gateway that Event Espresso includes can support this feature.


BurntCorkMedia

January 3, 2014 at 3:55 am

Yes, please submit a request. In the meantime, I would like to know how everyone else is using PayPal Pro since it is a requirment that 3D security is in place. Please advise.

Thanks


Dean

January 3, 2014 at 5:23 am

Hi,

3D secure is not a requirement for PayPal Pro but can be implemented for UK based merchants. US and Canadian merchants can implement it but PayPal ignores it.

Barring added security, its main purpose seems to be to enable participation with Verified by Visa and MasterCard SecureCode programs.

https://developer.paypal.com/docs/classic/paypal-payments-pro/integration-guide/ThreeDSecure/


BurntCorkMedia

January 15, 2014 at 4:19 am

Hi Guys, I’ve spoke to Paypal at length and they have suggested that I come back to you guys since they believe there is some conflict that is preventing transactions going through to do with the plug in. I’ve had various error messages so far and th current favourite is:

Sorry, there was a security error and your registration was not saved.

So clients can’t even get to the second page. Would really appreciate a fast response on this.

Please let me know if you require further details

Thanks


Tony

  • Support Staff

January 15, 2014 at 4:45 am

Hi,

Sorry, there was a security error and your registration was not saved.

Is due to caching, I can see the site currently has WP-Super-Cache installed, you need to set all of Event Espresso pages to not cache.

Within WP-Super-Cache this is done within Settings -> WP Super Cache -> Advanced.

Add /event-registration/, /thank-you/, /transactions/ to the rejected url list. http://d.pr/i/5atO

*Note the above page slugs are the default ones created by Event Espresso, if you have changed these you’ll need to use the updated page slugs.

You’ll likely need to rebuild/purge the cache after doing this.

Then test again.


BurntCorkMedia

January 15, 2014 at 5:37 am

Hi Tony

Thank you for your swift response. I’m afraid that did not cure the problem. I also tried turning the plug in off. Any other suggestions would be greatly appreciated.

Thanks


Tony

  • Support Staff

January 15, 2014 at 5:56 am

No problem πŸ™‚

Disabling the plugin does not disable the caching. Did you just disable the plugin or remove all the caches?


BurntCorkMedia

January 15, 2014 at 6:14 am

Actually, the website is also with Cloudflare – does that make a difference also?

(I only disabled the plug in having cleared the cache immediately prior – but I did add the strings as you suggested first).


Tony

  • Support Staff

January 15, 2014 at 6:27 am

If you view the page /event-registration/?ee=34

Then view the source for that page you’ll see

<--WP-Compress-HTML Uncompressed size: 80071 bytes; Compressed size: 73879 bytes; 7.73% savings-->
<-- Dynamic page generated in 1.731 seconds. -->
<-- Cached page generated by WP-Super-Cache on 2014-01-13 11:07:04 -->

So the page is still loading from cache, this could either be WP-Super-Cache or Cloudflare caching. The error message you mentioned earlier is usually caused by caching, so this is the first thing to remove from the equation.

Do you mind if I run a test registration on the above event?

*Some users prefer us not to link to their site within the forums, as there are no external links to your site here I have not linked directly. So replace *yourdomain.com* with your sites URL.


BurntCorkMedia

January 15, 2014 at 6:38 am

Oh, YES PLEASE!!! Go right ahead! πŸ™‚


Tony

  • Support Staff

January 15, 2014 at 6:59 am

The main event-registration page is not caching, but all the event pages are, which it likely what is causing your problems.

Can you re-enable WP-Super-Cache. On the main settings set Caching to off, save the settings, then Delete the cache. Then deactivate.

If you login to Cloudflare and look under Settings-> CloudFlare Settings-> Performance Settings. Can you disable caching there?


BurntCorkMedia

January 15, 2014 at 7:16 am

Hurrah!

Ok, looking good. I’ve done a couple of test runs and I’ve got through byt setting cloudflare to CDN only and WP-S-Cache off as instructed. Excellent stuff…

Now I need to claw back some seconds as it’s the load time is now up to 5s. Can you advise on sorting the event pages please.


Josh

  • Support Staff

January 15, 2014 at 7:57 am

Can you clarify what you mean by sorting the event pages?


BurntCorkMedia

January 15, 2014 at 8:02 am

Hey Josh, I refer to Tom’s quote:

“The main event-registration page is not caching, but all the event pages are, which it likely what is causing your problems.”

I’m hestitant to turn wp-s-cache back on. I’m assuming to leave cloudflare at CDN only status.

Thank you ver much boys for your swift responses btw!


Tony

  • Support Staff

January 15, 2014 at 8:38 am

The event pages are now fixed, if you look at the page source code you’ll see the comments from WP-Super-Cache are no longer there.

Here’s a rough guess as to what I suspect happened, WP-Super-Cache cached all pages including /event-registration/?ee=** pages, then CloudFlare cached that cache and served that because its caching was set to Simplified/Aggressive? (I suspect aggressive from the description)

Activating Wp-Super-Cache now may work now its set to ignore Event Espresso pages, but tbh I’m not sure, this is caching within caching.

I ran though a test registration on the event and found no issues now, however I did stop at the payments options.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 6 years, 8 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!