Home Forums Event Espresso Premium Very Urgent – ThemeRoller Not Changing

Very Urgent – ThemeRoller Not Changing

Posted: November 19, 2012 at 7:54 am

Douglas Nelson

November 19, 2012 at 7:54 am

I have lost buttons on my registration process and it seems like this happened when I switched my ThemeRoller settings. I need this fixed urgently as people are no longer available to register on the site. Please look here:

After you fill in your information and hit submit the buttons disappear as you go to the next step to confirm? Please let me know what I need to do to fix this issue!


  • Support Staff

November 19, 2012 at 8:01 am

Hi Douglas,

Which Themeroller options were switched, and what were the specific settings that were switched from and switched to?

Douglas Nelson

November 19, 2012 at 8:59 am

I put themeroller on and switched the theme to flick. Before, it was not on or set to default I believe. I also added the magic member plugin could that have affected it?

Douglas Nelson

November 19, 2012 at 9:16 am

The problem is if I try and change the themeroller settings to either No or default, it automatically puts Yes and flick back in the boxes after I hit save?


  • Support Staff

November 19, 2012 at 9:35 am

Hi Douglas,
There are two issues going on here. The first one is that themeroller settings aren’t getting updated when saving. I’m finding this to be the case on my test site, and will investigate this further.

The other issue, specific to your site:
It looks like the theme is overriding some of the theme roller styles, specifically with the confirmation button on the confirmation page. Basically what’s happening is themeroller is applying dark grey text on a white background, with a black border around the buttonYou can try adding some additional style rules to your theme’s custom style sheet in order to get that button to display.

So you can try adding something like this to your theme’s custom styles to override it:

p.espresso_confirm_registration input[type="submit"] {
border:solid 1px red;

While we are sorting out the themeroller not saving issue, another work around you can try is to set the “Skip Confirmation Page during Registration Process?” option in Event Espresso>General Settings>Advanced Features to yes, and the confirmation page will be bypassed.


  • Support Staff

November 19, 2012 at 11:08 am


I found an issue with the logic where it checks for templates in /wp-content/uploads/espresso/templates that affects the themeroller options. If you have any templates in /wp-content/uploads/espresso/templates, you can temporarily rename that directory and then switch the themeroller settings. I’m going to create a ticket so this gets fixed in a future update.

The support post ‘Very Urgent – ThemeRoller Not Changing’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso