Support

Home Forums Event Espresso Premium Urgent: Payments not working since updating EE4 and Stripe addon

Urgent: Payments not working since updating EE4 and Stripe addon

Posted: December 10, 2020 at 2:02 pm


baacademy

December 10, 2020 at 2:02 pm

Hello,

I have updated event espresso and Stripe and all of my payments now don’t work.

When I click “Pay Now” nothing happens and all of my customers have alerted me to it.

I have had to switch to Paypal.

Please can you have a look ? I cannot see many error messages as nothing happens when clicking “Pay Now”.

I give you permission to activate stripe again and test this yourself.

**REMOVED**


baacademy

December 10, 2020 at 2:03 pm

This reply has been marked as private.


Tony

  • Support Staff

December 10, 2020 at 2:58 pm

Hi there,

We will never ask you to post credentials on the forum, as you’ve found, they are public and its bad practice to post credentials on the forum even if private.

In the future, to securely submit your credentials please use this form:

https://eventespresso.com/send-login-details/

However, right now we don’t need any credentials as I can reproduce this and we are investigating, I will update you with any findings shortly.


Tony

  • Support Staff

December 10, 2020 at 3:25 pm

Hi there,

I’ve applied a temporary solution to your site which now allows Stripe to load again, we’ll be pushing an update to Event Espresso to work around the issue found here shortly.


baacademy

December 11, 2020 at 2:43 am

Thanks for looking into this Tony.

We have disabled PayPal for now as their fees are too high and can confirm Stripe is properly working again.

Do you know when the update will be ? Will we be able to use the Stripe Elements integration as the Legacy one is not great for EU customers.


Tony

  • Support Staff

December 11, 2020 at 3:48 am

The update is already live, if you don’t see it on the site go to Event Espresso -> General Settings and hit save, that forces a re-check.

Will we be able to use the Stripe Elements integration as the Legacy one is not great for EU customers.

Yes, you can switch over to elements at any time.


baacademy

December 11, 2020 at 6:47 am

Hello,

Sorry just to add to this issue. I can confirm I haev updated to the latest version and switched to “Stripe Elements”.

I have attempted a payment and it has been declined, however, when we use Legacy integration it works.


Tony

  • Support Staff

December 11, 2020 at 8:37 am

Hi

When you say it was declined, did it show an error message?

The support post ‘Urgent: Payments not working since updating EE4 and Stripe addon’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 months, 2 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!