Home Forums Event Espresso Premium Upgrading to wrecks wp-admin

Upgrading to wrecks wp-admin

Posted: December 12, 2012 at 11:55 am

Civitas Institute

December 12, 2012 at 11:55 am

Upgrading to Event Espresso from using WordPress 3.4.2 causes the entire wp-admin area to grind to a halt, finally returning 404s after several minutes. The log indicates premature end of script headers, as if it’s run out of memory. Things start to clear up after about half an hour once I roll back to, but obviously that’s not a permanent solution, since the new version has made database changes.

The front end (including registration) appears to work fine with the new version, however.

Any idea why that would be happening?


  • Support Staff

December 12, 2012 at 12:25 pm

Event Espresso 3.1.29 uses more memory than 3.1.28 did. We are not sure why, but the dev team is looking into it.

I’m finding that from time to time, if you’re really close to running low on memory, a bump like this can happen.

Can you try increasing the amount of memory available to PHP by editing the wp-config.php file?

Civitas Institute

December 12, 2012 at 1:43 pm

Wordpress’ memory limit was already set to 500M. However, I found through that link that FastCGI uses substantially more memory than CGI, so I set the server to CGI. Memory use did indeed drop substantially, but the admin panel still stalls for several minutes, though it returns “bad gateway” instead of 404 now. Doesn’t seem to be a memory problem, then.


  • Support Staff

December 12, 2012 at 3:22 pm

Hi there,

Is that happening on the admin only or the front end too?

Civitas Institute

December 13, 2012 at 7:37 am

Only on the admin. The front end seems to run fine.


  • Support Staff

December 13, 2012 at 8:07 am

Is this with running? It may be the change from FastCGI to CGI.

There may be other plugins conflicting here, and if so, you may be able to narrow these down by re-naming the plugin(s) folders in the plugin directory.

When you set the memory limit, was that via the wp-config.php file? Sometimes the host will not let you increase the memory this way.

Another thing you could try is to log into the site using another browser.

One other thing that may help: You can disable the dashboard widgets that load up RSS feeds from other sites by adding this to your theme’s functions.php file:

// disables ee news widget
function remove_espresso_news_dashboard_widget() {
  remove_action('wp_dashboard_setup', 'espresso_news_dashboard_widgets');
add_action('wp_dashboard_setup', 'remove_espresso_news_dashboard_widget', 9);

// disables WP RSS feed widgets
function remove_dashboard_widgets() {
  global $wp_meta_boxes;
add_action('wp_dashboard_setup', 'remove_dashboard_widgets' );

Civitas Institute

December 18, 2012 at 8:45 am

Turns out it was a Dreamhost issue that just happened to start when I upgraded, and then ebb and flow after that as I switched back and forth. Sorry for the trouble.

The support post ‘Upgrading to wrecks wp-admin’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso