Support

Home Forums Event Espresso Premium Upgrade to Latest Versions of EE3 and WP

Upgrade to Latest Versions of EE3 and WP

Posted: June 10, 2015 at 5:07 am


Ronald Aoki

June 10, 2015 at 5:07 am

Hello,

We are currently running the following versions:

– Event Espresso version 3.1.36.4.P
– WordPress version WP 3.8.8

We would like to upgrade to the latest version of EE3 and WordPress 4.2.2.

Are there any know issues that we should know about, or will everything on our site continue to work smoothly? (We’d like to keep it that way because EE3 is working great!)

Please advise. We would really like to upgrade to the latest versions but are very hesitant.

Thanks in advance.


Dean

June 10, 2015 at 5:36 am

Hi Ronald,

There are no known issues with that upgrade step.

As always though, I would still recommend doing a database back up at the very least (better safe, than sorry).


Ronald Aoki

June 11, 2015 at 4:41 am

Thanks, Dean.

Upgraded to WP 4.2.2 with no issues.

New question: Being that version 3.1.36.4.P of EE3 (from Jan. 2014) is working great for us with no issues, should we continue to use this version or do you recommend that we upgrade to the latest version of EE3?

The “unknown” status of its compatibility with WP 4.2.2 is a little worrisome.

Please advise.

Thank you.


Tony

  • Support Staff

June 11, 2015 at 4:59 am

Hi Ronald,

WordPress 4.2+ introduced security fixes to WP that the latest version of Event Espresso accommodates for, therefore I would recommend updating to the latest version.

However have you had any custom development work done to Event Espresso at all?

It is always a good idea to backup your site before updating any plugins, themes or WordPress itself. At least a database backup but a full site backup if possible, there are many plugins available to help with this, a break down is of some of the well known plugins is available here:

http://www.wpbeginner.com/plugins/7-best-wordpress-backup-plugins-compared-pros-and-cons/


Ronald Aoki

June 11, 2015 at 5:17 pm

Hi, Tony.

Thank you for the reminder. I did back up the data and files prior to upgrading to WP 4.2+ and then commenced said upgrade along with a few plugins, but did not upgrade to the current EE3 yet.

I did do some custom CSS to my child theme of the Twenty-Thirteen theme. I just noticed that when I view the site on a smartphone, the header no longer displays correctly. It cuts off half of the header image. Strange. It never did that before until after said upgrades.

The header displays fine via computer, but when the site is resized down for smartphone viewing, it does not respond accordingly anymore. Any thoughts? Does my CSS code below need to be changed:

@media only screen and (min-device-width : 320px) and (max-device-width : 480px) {

Please advise.

Thanks, again.


Ronald Aoki

June 11, 2015 at 5:22 pm

Let me try and paste the custom CSS code in again with spaces in between, however, so that it shows the entire code:

@ media only screen and (min-device-width : 320px) and (max-device-width : 480px) {


Ronald Aoki

June 11, 2015 at 5:27 pm

See this CSS discussion in a previous support topic of mine here:

http://eventespresso.com/topic/registration-page-decreases-in-size-on-iphone/


Josh

  • Support Staff

June 11, 2015 at 7:46 pm

Hi Ronald,

It may help to compare the CSS changes from the earlier version of the twentythirteen theme to the new version. You can get archive copies from here.


Ronald Aoki

June 11, 2015 at 10:12 pm

Hi Josh,

I created a child theme of twenty thirteen though and that’s the theme that I am using. What would affect the CSS on my child theme?

Please advise.

Thank you.


Dean

June 12, 2015 at 4:34 am

Hi Ronald,

Is it code similar to this?

@media only screen and (min-device-width : 320px) and (max-device-width : 480px) {
.facebook-button div span iframe {
min-width: 100px;
max-width: 100px;
}
}

If so that code does not exist in your child theme (I searched it for 480, but it wasn’t found).

I think the current chopped image has something to do with this:

@media (max-width: 359px)
.site-header {
  background-size: 360px auto;
}

Event Espresso would not have affected the theme CSS, so I would guess it’s either a CSS conflict between the child theme’s CSS and the (updated?) Parent theme’s CSS or perhaps someone has modified your child theme’s CSS.


Ronald Aoki

June 13, 2015 at 12:48 am

Thanks, Dean.

I think the header issue was indeed a conflict between the CSS in my 20-13 child theme and the new CSS in the 20-13 parent theme, which I also upgraded to the latest version from 1.1 to 1.5 when I upgraded to WP 4.2.2.

So I deleted the latest version of the 20-13 1.5 theme via my cPanel and replaced it with a copy of the 1.1 version and now the header issue is resolved. I guess I should have never upgraded the 20-13 1.1 parent theme, right?

Now, however, I noticed that in mobile device view, the drop-down menu, when clicked, no longer shows the drop-down sub items like how it did before. It only shows the top menu items. Not sure how to fix this. Any thoughts?

Going back to the topic of upgrading to the latest version of EE3, the latest version is no longer available in my Plugins update list so I cannot update to EE3 3.1.37.4.P. Do you know why? Or should I download it from my dashboard and upload and install it manually?

Thanks again.


Ronald Aoki

June 13, 2015 at 3:02 am

Hello,

Update: Drop-down menu in mobile view fixed. Now all sub menus are displaying accordingly.

This is the main question I have now:

“Going back to the topic of upgrading to the latest version of EE3, the latest version is no longer available in my Plugins update list so I cannot update to EE3 3.1.37.4.P. Do you know why? Or should I download it from my dashboard and upload and install it manually?” Or am I no longer allowed to update to the latest version of EE3?

Thanks, EE!


Josh

  • Support Staff

June 13, 2015 at 7:21 am

Hi Ronald,

I don’t know why you’re not seeing an update notification there, but you can follow this guide to manually update Event Espresso 3:

http://eventespresso.com/wiki/updating-event-espresso/#update_manually

Please make sure you download Event Espresso 3 and not Event Espresso 4 from your account page.


Ronald Aoki

June 18, 2015 at 10:54 pm

Everything is updated to the current versions and running smoothly.

Than you all!


Tony

  • Support Staff

June 19, 2015 at 2:39 am

You are most welcome, Ronald 🙂

Do let us know if you have any further problems.

Have a great weekend!

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 5 years, 3 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!