Support

Home Forums Translations Updated translation doesn't show up

Updated translation doesn't show up

Posted: July 10, 2015 at 4:21 am


Emil

July 10, 2015 at 4:21 am

Hi,
I’ve been approved yesterday as a Romanian translator for EE4. I’ve already translated a bunch of strings, saved the new .po and uploaded it to my website (in this folder /wp-content/uploads/espresso/languages/), but I see no change on the frontend. I did clear my cache in the browser and refreshed the events page, but nothing new happened.
The website is http://www.hooponoponoromania.ro.
Please check and let me know what do I have to do in order for the new translation file to be effective.
Thank you.
Best Regards,
Emil


Dean

July 10, 2015 at 5:02 am

Hi,

Is your Wp-Config.php set for Romanian?

https://codex.wordpress.org/Installing_WordPress_in_Your_Language#Single-Site_Installations


Emil

July 10, 2015 at 5:12 am

Yes it is.


Tony

  • Support Staff

July 10, 2015 at 5:15 am

What is the full filename of the po/mo files please?


Emil

July 10, 2015 at 5:17 am

It’s event-espresso-4-ro.po, I don’t have any .mo one, this .po is the one exported from GlotPress and which I was advised to placed in the above specified folder.


Tony

  • Support Staff

July 10, 2015 at 5:31 am

Did you follow a guide for this? If so can you post a link to the guide you followed (If its one of ours I’d like to update it to make it clearer if that’s the case)

Rename the .po file to event-espresso-4-ro_RO.po on your local machine

A .po file is the human readable version of the translations. Its where you make changes to the translations using POEdit.

WordPress won’t load a .po file directly, it needs the .mo file (which is made from the PO file) The .mo file is basically all of your same translations within the PO file, but in machine code. POEdit will create the .mo file when you save (File -> Save). This file will be created in the same location as the PO file you opened.

So if you rename the PO file.

Open it in POEdit.

Click Save.

You’ll now have a file event-espresso-4-ro_RO.mo

Using FTP upload that MO file to /wp-content/uploads/espresso/languages/

The new translations should then appear.

***

It is also possible to do this through GlotPress, change the dropdown for the Export before clicking the ‘Export’ link – http://take.ms/Oimh6

However you may still need to rename the MO file after download to match your local. (It will be event-espresso-4-ro.mo, it needs to be event-espresso-4-ro_RO.mo)


Emil

July 10, 2015 at 5:36 am

I’ve uploaded now the .mo with the same name as the .po: event-espresso-4-ro.mo (I wasn’t aware that I can export both formats from GlotPress, sorry). Still doesn’t work


Emil

July 10, 2015 at 5:39 am

Thank you, adding the .mo file and renaming both with _RO at the end did the trick.
Thanks again, mark this as solved.

The support post ‘Updated translation doesn't show up’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Emil 5 years, 6 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!