Support

Home Forums Translations Untranslated Text

Untranslated Text

Posted: June 3, 2015 at 5:16 pm


Gonçalo Pereira

June 3, 2015 at 5:16 pm

Hi!

I’m working on a custom translation with the latest Portuguese file (downloaded in 2015-06-03). In some cases I’m also using the “Quick Localisation” plugin to translate text that isn’t available in the language file.
Unfortunately I found some text’s that are still untranslated:

1 – In the event main page, the buttons “More Dates” or “Less Dates” ;
2- In the “Payment Options” step: The description includes the prefix (For [Event Name]) – How can I translate the word “For”?
3 – In the same step, the messages displayed after “Important Information Regarding you payment” remain in English although they are translated in the language file (using invoice and paypal).

In this three cases I also tried unsuccessfully to use the plugin…

Thanks


Lorenzo Orlando Caum

  • Support Staff

June 4, 2015 at 10:08 am

Hi there Gonçalo,

Some of the items on your list does not sound familiar. Could you provide a link to any event on your site?

Also, please ensure that your software is up to date as we troubleshoot on the current release.


Lorenzo


Gonçalo Pereira

June 4, 2015 at 10:18 am

Hi Lorenzo!
All the software is up to date (I also the latest PT language files).

Our site is under development here: redacted – Event Espresso support team – LOC

Most of it is already translated to portuguese so, if you need further assistance please let me know.

Thanks


Lorenzo Orlando Caum

  • Support Staff

June 4, 2015 at 11:27 am

Hello again Gonçalo, those buttons need to be updated to be translation ready. For a workaround, you can adjust the messaging for the buttons in this location at around line 526:

/wp-content/themes/iced-mocha/theme-functions.php

https://github.com/eventespresso/iced-mocha/blob/1f6401e60c466e877659e1f94e36ec48f1b9ca30/includes/theme-functions.php#L526

We are working on your second question to make that “For” translation ready.

Could you share a screenshot of your third issue? Your website has a login during registration checkout so I couldn’t get that far.

http://eventespresso.com/wiki/troubleshooting-checklist/#screenshots

If this is the messaging on the payment methods when they are selected, then try adjusting the messaging through the payment methods description are within Event Espresso –> Payment Methods.


Lorenzo


Gonçalo Pereira

June 5, 2015 at 3:30 am

Hi Lorenzo,

Thank you very much for your reply.

As requested:


Tony

  • Support Staff

June 5, 2015 at 6:45 am

Hi Gonçalo,

That’s actually the payment method ‘description’ and is available within the settings.

If you go Event Espresso -> Payment Methods -> Click on the payment method (in my example PayPals Standard) you can edit that description there – http://take.ms/t7ugj

Any edits you make there will be visible here – http://take.ms/vnJTz

Same goes for the Invoice – http://take.ms/uwESf


Gonçalo Pereira

June 5, 2015 at 9:57 am

Hi!

Thank you very much for your help. I apologize for not looking at this first.
I have changed the button labels as described and it worked just fine.
Please let me know when my second point is solved.

Thanks


Josh

  • Support Staff

June 5, 2015 at 3:32 pm

Hi Gonçalo,

A little update on this: Event Espresso 4.6.30.p was released today and it includes a fix for the issue you reported here (the issue for “for”). Thanks for reporting.

The .pot files may not get updated right away, so you can alternatively use a translation function if your po file does not include the string for “for”.


Lorenzo Orlando Caum

  • Support Staff

June 5, 2015 at 4:23 pm

Hello again Gonçalo, we’ve updated the translation files.

You can download the updated version here:

http://translate.eventespresso.com/projects/event-espresso-4/pt/event-espresso-pt_PT

Then you can use a tool like POedit to merge your existing language file into the new one:

http://stackoverflow.com/a/16144606

Thanks again for bringing these translation issues to our attention.


Lorenzo


Gonçalo Pereira

June 8, 2015 at 2:23 am

Hi Josh and Lorenzo.

Thank you both for your feedback. Later today I’m going to merge the language files and test it.
I’ll report on the outcome.

Thanks again.


Gonçalo Pereira

June 8, 2015 at 7:08 am

Hi!

All items solved.
Thank you very much for you support.

Excellent work.

The support post ‘Untranslated Text’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Gonçalo Pereira 5 years, 7 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!