Home Forums Event Espresso Premium Unsafe Content Loading on Protected Pages (HTTPS SSL) Originating from EE Plugin

Unsafe Content Loading on Protected Pages (HTTPS SSL) Originating from EE Plugin

Posted: October 12, 2012 at 1:03 pm


October 12, 2012 at 1:03 pm

This whole week I’ve been investigating as to why the SSL cert and HTTPS is causing errors/warnings in IE and Google Chrome when landing on HTTPS protected pages (Event Registration, etc.). Using chrome’s console I found 404 (Not Found) errors (see below) originating from “Event Espresso plugin/event-espresso/templates/event_espresso_style.css…”

Did we blush the install? Any recommendations for fixing?

Thank you


GET 404 (Not found) upcoming-events-calendar:23
GET 404 (Not found) upcoming-events-calendar:24
———–END OF ERROR—————-


October 15, 2012 at 6:02 am

Hi Bishop,

No its not a botched install, its to do with the HTTPS aspect. As far as I understand it its due to the site only being partly HTTPS on certain pages, the browsers don’t like it.

You could try this


October 15, 2012 at 3:04 pm

Hello Dean, I’ve referred to the resource page you provided above several times in my attempt to resolve this issue but no luck. My edit page view is difference than the edit page view in the screenshot on the instructions page, instead of “Force SSL” I have “Secure Post” and “Secure Child Posts” under the heading HTTPS in the admin sidebar.

I did note the “Note” on the resource page (Note: Before you start, be sure you have a private (non-shared) SSL certificate installed for your domain.). With at least two cooks I can’t say for sure if the the plugin was activated after or before ensuring the SSL certificate install. Can this be at the root cause of the issue? Simply deactivating the HTTP’S plugin and reactivating it doesn’t change anything, maybe an uninstall followed by installation the plugin?


October 16, 2012 at 3:29 am

Hi Bishop,

Did you set the Secure Post for those pages? Have you tried setting the SSL site wide?

If needed, please send login details via

Choose the “I am sending login info as requested” option and fill out the form


October 16, 2012 at 11:28 am

Hello Dean, yes I did set the Secure Post for those pages. What I had not tried, to prevent complicating the SEO schema for the site, was the implementation of site wide SSL until moments ago and it worked, but the whole site?

Resolution, or workaround? Sometimes it’s the same difference. We’ll need to compensate for going HTTP to HTTPS with canonicalization and 301 redirects, but he site is young, small and it’ll heal quick

Awesome product, awesome support. Thank you.

PS: If you still want access I’ll be more than happy to email log-in credentials. Thanks again.


October 17, 2012 at 12:05 am

Hi Bishop,

Honestly its more workaround than resolution.

Please still send login details as I would like to see why its not working just for those pages.


October 17, 2012 at 10:39 am

Whoa, just noticed that turning on site wide SSL broke some images. Revert site wide SSL to Force SSL Exclusively as a quick fix. I emailed my log-in credentials as requested. Thank you.

Chris Reynolds

  • Support Staff

October 17, 2012 at 3:37 pm

Thanks for sending your login info. I wasn’t able to get your events registration page to load at all at first. I was able to resolve this by disabling the “Force SSL Exclusively” setting (which I realize is contrary to our documentation). The page loads now, but the Add to Cart link doesn’t function properly and on the registration page the add/remove attendee icons don’t display. The console log gives me this:

 GET 404 (Not found) event-registration:23
 GET 404 (Not found) event-registration:24
 GET 404 (Not found) event-registration:24
 GET 404 (Not found) event-registration:24
 GET 404 (Not found) event-registration:24
 GET 404 (Not found) event-registration:24
 GET 404 (Not found) 

When I go to any of those urls to the scripts (either with http or https) I get a 404 error, which explains why the error in the console and why it’s not working on the site. I’m wondering if there’s a permissions issue preventing those files from being accessible?


October 17, 2012 at 4:26 pm

Hello Chris, good observation. I’m assuming you’re referring to the permissions for the several files…I went in the server and noted that permissions to the EE plugin is set to Read, Write, Execute, User(7), Group(0), World(0), and yes they’re blocked to the outside world. Would you be able to provide me with the appropriate file permissions? Thanks.


October 17, 2012 at 6:36 pm

Hello Chris, after revisiting your notes above I’m getting the sinking feeling that this may be a corrupt install – Too many things are not working. I’ve been reading related forum topics and invested quite a bit of time researching but to no avail. I can afford to take the site down late evening and perform a re-installation of the related plugins “EE” & “WordPress HTTS (SSL)”. My only concern are the events I’ve already created and advertised – will they (Events) be preserved between the uninstall and re-install processes, or would I need to recreate them?

PS: I had to enable “Force SSL Exclusively”. Leaving it disabled causes non-https images to break.


October 17, 2012 at 9:25 pm

Hello Chris, the keyword is “Permissions”. I looked at the server directories and files and found that ALL EE folders and files had the permission setting of 700. One by one I assigned folders 0755 and their respective files 0644 permission levels. Issues resolved. Being the first time working with EE I didn’t know what to expect on admin pages, now that permissions have been changed I see more of a feature rich UI. Before closing, I would like to ask; are there any folders or files that require a tighter permission level than 0755 or 0644, respectively? Otherwise, this puppy is ready to close as resolved.

I’ll wait to hear back, thank you.


October 17, 2012 at 11:38 pm

Morning Bishop,

Im glad that the culprit was found.

The permissions are fine to be set at 644/755 for Event Espresso stuff.

Just a few answers. Removing Event Espresso will not harm the events, they are saved in the database and as an extra measure we dont remove them when the plugin is removed.

You can use an FTP program like Filezilla to change file permissions on masse.

I will mark this one as resolved for you.

The support post ‘Unsafe Content Loading on Protected Pages (HTTPS SSL) Originating from EE Plugin’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso