Support

Home Forums Event Espresso Premium Turn off WordPress auto formatting just for EE emails?

Turn off WordPress auto formatting just for EE emails?

Posted: July 5, 2012 at 4:37 pm


Bill

July 5, 2012 at 4:37 pm

Here’s registration email code that I entered into general settings:

Thank you (fname) for registering for the (event)! Here is some information about the event for your records:(br /)

(strong)Event Description:(/strong)(br /)

(description)(br /)

(strong)Date:(/strong) (start_date)(br /)

(strong)Departure Time:(/strong) (start_time)(br /)

(strong)Departure Address:(/strong)(br /)

(venue_title)(br /)

(venue_address)(br /)

(strong)Link to the event page:(/strong) (event_link)(br /)

Make sure to bring your ticket with your when you board. If you can’t find your receipt email, it may have been picked up by your spam filter so check you spam folder. If you have any questions, please call us at (000) 000-0000.(br /)

Sincerely,(br /)

The SF Bay Photo Club Team(br /)

(strong)Reminder(/strong) Call (000) 000-0000 after 7:00 p.m. the night before your trip to verify that the trip is going out as scheduled. You will hear a recording for the status of the trip scheduled for the following day.(br /)

(ticket_link)(/p)

I replaced [] and with () so I could post it here without problems. I’d like to remove the br tags after description, departure address, and venue title. But when I do that and press update, wordpress adds p tags to where the br tags used to be and then the formatting on my email looks bad. If I can prevent the p tags from adding themselve, my email would look perfect! Do you guys know how I can go about doing this?


Josh

  • Support Staff

July 6, 2012 at 7:13 am

Are you composing this email in the html mode or the visual mode of the editor?


Bill

July 6, 2012 at 8:34 pm

I am composing this email using the html editor. Here’s a screenshot of what the email looks like: http://i.imgur.com/xUNRi.jpg

The yellow rectangles represent the space that I’m trying to have removed.

I know this is pretty nitpicky. My client mentioned the spacing of the the registration and purchase emails. I had to remove most of the p tags in favor of br tags in the emails or else the emails would be triple spaced after each “paragraph”. I was curious if you knew a way to deactivate auto formatting from these emails that I created under Event Espresso general settings but also leave the rest of the site formatting intact. If you aren’t sure then I just wanted you guys to be aware of the email spacing for future versions of EE. Thanks for the great plugin!


Josh

  • Support Staff

July 9, 2012 at 7:47 am

You should be able to remove the line breaks in html mode. WordPress will add a br tag for one return, and a p tag for every double return.
example

The support post ‘Turn off WordPress auto formatting just for EE emails?’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Josh 8 years, 4 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!