Support

Home Forums Translations Translation not working (tried almost everything)

Translation not working (tried almost everything)

Posted: February 22, 2013 at 7:44 am


Joona Nuutinen

February 22, 2013 at 7:44 am

I have successfully translated WordPress, and the theme to Finnish. Theme displays dates and times correctly, but Event Espresso still shows everything only in English.

I have tried
– Installing the language files to uploads/espresso/languages
– Installing the language files to event-espresso/languages
– Tried them on both locations at once and separately on each
– Renaming readymade language files to fi_FI (in both locations)
– Renaming readymade language files to event-espresso-fi_FI (in both locations)
– Using Codestyling Localization to translate

No success. What am I doing wrong?

Are the language files in Github already named correctly, or do they need to be renamed?

Which location is the default location? If I leave both directories empy, Event Espresso will not download a language file to either folder. Should it?

Early development version of the website can be found here: http://www.netura.fi/espoonsulkapallo/kalenteri


Dean

February 22, 2013 at 8:17 am

Terve Joona,

The files (event_espresso-fi.mo and event_espresso-fi.po need to go to the wp-content/uploads/espresso/languages folder. That should by default have an index.php file there. If not add a blank one.

The Finnish language files are only about 60% complete, so not everything is showing. Eg http://d.pr/i/S69K the menus are in English but labels in Finnish.

Is this a single site WP installation or MultiSite?


Joona Nuutinen

February 27, 2013 at 2:38 am

It’s a single WP installation. I was able to get it partially working by creating a fresh installation on a different server. I installed and translated WP first, and then installed EE. I noticed that if I upload the translation files to the folder you suggested, it does not work, but, the language file was downloaded to plugins/event-espresso/languages automatically, and that version did work on the admin side, and on the event registration page, but the calendar page (using the shortcode [ESPRESSO_CALENDAR]) remains untranslated. Why?

I guess my question should have been: how do I translate the Calendar plugin? I’m under the impression that it should use the month and date translations from WordPress itself. The date translations work in blog posts, so why not in the Calendar plugin? Do I need to translate the plugin too? If so, is there a separate language file for the plugin, or is everything in the same language file?


Joona Nuutinen

February 27, 2013 at 6:36 am

Ok, I guess I was blind. I found the translations on the settings page of the calendar plugin. It is a rather non-standard way of doing things, though.


Dean

February 28, 2013 at 2:38 am

Hei Joona,

OK, well I am glad you have it resolved. I will make a note about the calendar translations to see if we can do something about that in future versions.


Martin Casteres

February 28, 2013 at 12:56 pm

Hy !
I have the same problem for the translate files… Tried everything said adove… Still don’t have luck…
My worpdress is correctly in french, my languages files are correctly named, but neither in the “wp-content/uploads/espresso/languages” folder nor in the “plugins/event-espresso/languages” folder the files works…
What have i done wrong ?
Is it because of developping on local (before push it over my client’s site)
Thanks for your help !


Josh

  • Support Staff

March 1, 2013 at 4:36 am

Hi Martin,

I don’t think it’s not working because it’s on local. In your wp-config.php file, what is define('WPLANG' set to?

Also, which files are in /wp-content/uploads/espresso/languages? Specifically, what are the file names?


Dean

March 1, 2013 at 5:19 am

Hi Martin,

Can you check the file size of the MO file please? If it is small, 25kb or so, then you will need to re-download the file.

Go to https://github.com/eventespresso/languages left click the MO file for the language you need and then click the View Raw link in the middle.

This will download the correct file, add that to uploads/espresso/languages and you are good to go.


Martin Casteres

March 2, 2013 at 2:22 am

Okaaaayyyyy !!!! Got it !!!
Thank you guys !!
In fact, the other day, as i was looking for the .po and .mo files (quit a long time searching), i didn’t found that Github link and i’ve download them via GlotPress !! So, i thought it was correctly named ! How stupid am i 😉 The download file was named : “event-espresso-fr_FR.po” ! It wasn’t an underscore between “event” and “espresso”, that all !!! 😉 Ha ha ha !
Thank you for that Github link !
Great work !


Dean

March 3, 2013 at 9:06 am

Thanks, and glad its working now.

The support post ‘Translation not working (tried almost everything)’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Dean 8 years ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!