Support

Home Forums Translations Translation file bug (?) makes attendee record appear as incomplete

Translation file bug (?) makes attendee record appear as incomplete

Posted: March 1, 2013 at 11:14 am


Even Onsager

March 1, 2013 at 11:14 am

I’m test driving 3.1.30.7 on a local server before updating our site, and I’ve run into a weird and ultimately disastrous (since the site will not work unless solved) problem that seems to be translation-related. (Sorry for the long-winded post, but I find it best to describe what I did beforehand to avoid follow-up questions like “did you try disabling plugin x, y and z?”)

I clean-installed WordPress 3.5.1 nb_NO (Norwegian), EE 3.1.30.7 and everything installation-related went smoothly (including auto-downloading the correct .mo file). After going through and recreating the settings pages one by one (I wanted to do everything by hand, no importing, to keep the mysql db clean), I set it up the way I wanted it, and created a test event. So far so good, I’ve done this before (albeit no auto-download of lang-files in the past), and everything seemed normal. Registrations worked, emails got sent, etc.

But for some reason no event attendee counts in the event overview (it says “0/10” (10 being the limit)). When I click the 0/10 link, I find all my reg id’s are indeed accounted for in the attendee report, but they’re marked as incomplete payments with a red exclamation point. I’ve marked the default payment status as completed in the general settings, and I’ve also tried overriding the default setting on a per-event basis, but the only thing that works is approving the “payments” (this is a free event) of each and every reg id. Then they count, and it says “3/10” in the overview. Obviously, we can’t do this, especially because if I get 15 registrations on this event, it will not be listed as sold out until all attendee “payments” are manually approved, and by then it will be overbooked.

After changing the theme, disabling all plugins one by one, etc. with no luck, I tried changing the WP language to English through wp-config.php, deleted the Norwegian .mo file (unnecessary, I think?) – and everything suddenly magically worked. (I then re-activated all plugins and still had no problems, and everything is smooth (better than ever) when I run it in English.)

So obviously (to me, at least) there’s something deeply weird in the Norwegian language files for 3.1.30.7 (the problem was also present in 3.1.30.5, but then I thought I’d done something wrong and I didn’t suspect the language files). I’ve also tried editing strings I found suspicious in Poedit, but I didn’t find anything that worked. I also tried yet another clean install right now to see if I did something wrong the first time, but the problem is still there.

I have no idea what to try now, so I’m calling out for help.


Dean

March 3, 2013 at 9:44 am

Hi Even,

Firstly, thank you. It is great to get a clear and detailed account of what has happened.

I tested this locally myself and I can confirm what you are saying. It is however not just Norwegian, I tested with Swedish and Portuguese as well.

As such I am raising a developer ticket to look into it. My gut is saying it has something to do with a string being translated thus not being found by the code, but I am unsure of that.


Dean

March 3, 2013 at 10:48 am

Hi,

OK, the developers are one step ahead of me, this has been fixed in the next version due out shortly.


Even Onsager

March 4, 2013 at 2:58 am

That’s great to hear! We really want to get our site back up and running (in Norwegian) soon, since we have an upcoming event where the registration is due to start this Thursday.

Is that feasible (meaning a fix being up on Wednesday) or is it too soon for you? Normally, I would’ve thought it was too soon, but you’ve been really quick with some fixes recently, so I thought I should ask.


Dean

March 4, 2013 at 3:11 am

Hi Even,

I am not sure when the next update is due exactly but it is soon, the last items are being tested as we speak.


Even Onsager

March 4, 2013 at 3:15 am

I’m keeping my fingers crossed. Thanks for the quick reply.


Josh

  • Support Staff

March 4, 2013 at 8:25 am

Hi Even,

The beta of 3.1.31.P has been released to the pre-release channel, which includes the translation fixes. If you go to your account page and you don’t see the pre-releases, you can check the box to opt-in to the pre-release channel.

You might also like to know that 3.1.31.P has a new email shortcode that you can use: [ticket_qty]


Even Onsager

March 4, 2013 at 8:34 am

Beautiful! I joined the pre-release channel now, and I will set it up tonight. (So glad you created the new email shortcode, btw!)

The support post ‘Translation file bug (?) makes attendee record appear as incomplete’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Even Onsager 8 years ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!