Support

Home Forums Event Espresso Premium Time Slider No Longer Displaying In Datetime modal

Time Slider No Longer Displaying In Datetime modal

Posted: May 26, 2020 at 6:25 am


Phil Evans

May 26, 2020 at 6:25 am

Hi,
The time slider/selector has suddenly stopped working for me

Here’s a screen grab
https://imgur.com/a/7CYsgQN

I don’t see any errors or warnings showing up in dev tools.

Can you help?

Thanks

Phil


Tony

  • Support Staff

May 26, 2020 at 3:10 pm

Hi Phil,

That usually means something else is loading assets on the Event Editor and it’s replacing the version of datepicker used.

Did you notice this happen after your installed/updated a specific plugin/the theme?

The way I would troubleshoot this is using the WP Health Check plugin.

(Note, there have been reports of the above plugin crashing the site, I’ve never had any issue with it at all, but I recommend creating a database backup before you start using it just to be safe)

With the above plugin go to Tools -> Site Health -> Troubleshooting -> Enable Troubleshooting mode.

That plugin will then de-activate all plugins and switch to a default theme, but only for you, the logged-in admin. So now in the admin bar, you can activate individual plugins and test.

So activate Event Espresso and view an event, does it show the slider then?


Phil Evans

June 3, 2020 at 4:46 am

Hi Tony,

I’ve worked out what’s causing it. It’s Advanced Custom Fields. We added a custom field to each event for an event code. If we disable ACF then the sliders re-appear.
Any suggestions of how we can fix this?
Thanks

Phil


Seth Shoultes

  • Support Staff

June 3, 2020 at 10:30 am

Hey Phil,

You might try using the Web Developer tops in your browser to troubleshoot the issue. It might be that ACF is injecting some conflicting JavaScript or CSS into the event editor. If you can pinpoint the conflict, then we might be able to offer some suggestions.


Phil Evans

June 4, 2020 at 1:30 am

This reply has been marked as private.


Tony

  • Support Staff

June 5, 2020 at 7:07 am

What type of fields are you loading through ACF?

I’ve seen something similar happen when loading a DatePicker field as ACF can then conflict with the DatePicker used by EE but not with just standard fields.

I’ve just installed ACF (free version) on a test site and set up both a DatePicker field and then a Text field (which it sound like you are using) and the sliders appeared with both loading on the event editor.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 1 month ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!