Support

Home Forums Event Espresso Premium (Time Sensitive Support Token) EHD Mobile App QR Code / Manual Check-In Issues

(Time Sensitive Support Token) EHD Mobile App QR Code / Manual Check-In Issues

Posted: September 19, 2022 at 4:20 am


Critical Ops

September 19, 2022 at 4:20 am

Hi, I am using a support token and will link this thread to it.

The issue I am having revolves around the mobile app. When I first login, I received a pop up twice in a layer that says “error occurred, the request cannot be fulfilled due to bad syntax.” I click okay twice than I can use the app.

So now the important part, I navigate to the QR code scanner and when I scan a QR code I get registration denied and a pop up that says: “error occurred, the requested resource could not be found but may be available again in the future. Subsequent requests by the client are permissible.” Note I have used all three types of check in options.

Now if I go to do it manually, I just get the pop up but no registration denied. I have followed the troubleshooting steps and nothing has worked. I also used a REST API log and saw that the registration link was getting a 404 error which explains the pop up. I’m not sure what to do and my event is today. Obviously if all else fails it is a paper and pencil check in, but that is not ideal.

Thanks in advance for any help I receive with this issue, I truly appreciate it!


Garth

  • Support Staff

September 19, 2022 at 11:00 am

Can you link us to one of your events please?

Who is your hosting provider?

Do you run any caching plugins? (Or does your host run server side caching?)

Have you tried flushing the permalinks? (Go to Dashboard -> Settings -> Permalinks. Make no changes and just click Save)

Is the event still published?


Critical Ops

September 21, 2022 at 9:33 am

This reply has been marked as private.


Critical Ops

September 21, 2022 at 9:34 am

This reply has been marked as private.


Tony

  • Support Staff

September 21, 2022 at 4:25 pm

Hi there,

Firstly, thank you for adding the additional details, just so you know GoDaddy Manage WordPress packages have forced caching on all pages.

So, just to add some details for this I had a look at your site to see if I could see why this would happen.

The WP REST API link headers have been removed from the response on your server, this could have been done via code on the site, or something GoDaddy now does on their Managed WordPress hosting (add an eyeroll to GoDaddy here if thats the case).

What that means is when the app ‘logs in’ on the site, it would normally be able to read those headers and know where the requests should go, instead, those are missing so it has to do the best guess and on your site, its using HTTP to send the requests, which are then redirected to HTTPS.

That’s fine for GET requests (where the app is PULLING data IN) but you can’t do that with POST requests (where the app is SENDING data to the server for it do something)… like the QR request or the manual check-in request. Those send data over to the server and if those are being sent via HTTP and being redirected to HTTPS (which I’m fairly certain they are on your site) the data is removed from the request on redirect (server side because you can’t redirect POST requests like that) and the app then doesn’t know what to do with the response because it no longer makes sense.

Usually, people add code like this:

https://wordpress.stackexchange.com/questions/211817/how-to-remove-rest-api-link-in-http-headers

Or:

https://wordpress.stackexchange.com/questions/211467/remove-json-api-links-in-header-html/211469#211469

Which removes those headers, that may or may not be on your site. As mentioned it may be something GoDaddy now do with one of their MU-Plugins somewhere hidden away.

Either way I just wanted to add some additional context as to what I think happened here.


Tony

  • Support Staff

September 21, 2022 at 4:28 pm

Also, I’m sorry we couldn’t fix this for you for your event (I have not redeemed your support token and have forwarded your refund request).

However, I should note that unless the above code is indeed somewhere on your site (in a custom plugin or the themes functions.php file) were we could have commented it out to make sure the REST API links are included in the response I don’t think we would have been able to fix this in the timeframe for a support token. It looks like a config issue which are always hard to fix on a tight deadline.

You must be logged in to reply to this support post. Sign In or Register for an Account

Event Espresso