Support

Home Forums Event Espresso Premium Ticket selector incorrectly displays first datetime on mobile

Ticket selector incorrectly displays first datetime on mobile

Posted: June 7, 2021 at 2:20 am


ComedieTriomphe

June 7, 2021 at 2:20 am

Hey there,

I’ve had an issue for a while I can’t seem to fix: I’ve previously successfully configured the ticket selector so that it doesn’t display any tickets until the user physically pick a date from the selector, which works great on desktop.
Sadly, on mobile phones and regardless of the browser, the first date is always picked by default.

How can I fix it?

Here is a link to an event:

https://www.comedietriomphe.fr/events/gaga-de-saint-etienne-2/

Thanks


Tony

  • Support Staff

June 7, 2021 at 3:50 am

Hi there,

Just to confirm understand this correctly, on desktop I shouldn’t see any tickets at all to begin with?

I’m asking because when I view the link you gave using desktop, I do see tickets, for the first datetime:

https://monosnap.com/file/Dgz2MaE0yZMo4KEtwQ951IXlgPn3Jk

I hadn’t clicking anything there and those tickets loaded, I then opened up the datetime selector before taking the screenshot.


ComedieTriomphe

June 7, 2021 at 5:50 am

Hi Tony,

That’s strange. Look at how it looks when I click on that same link:

https://ibb.co/wWgHPDp

I believe I had used a trick found on this forum to achieve this, but can’t remember now… Do you?


ComedieTriomphe

June 7, 2021 at 5:58 am

I’ve tested it on chrome and it shows the same as you (working on firefox though).

I guess my next question is… How to appropriately get to the result expected?


Tony

  • Support Staff

June 8, 2021 at 4:19 am

I’ve tested it on chrome and it shows the same as you (working on firefox though).

Not for me, I get the same on both.

It looks like you are using the code from this thread:

https://eventespresso.com/topic/ee4-event-tickets-datetimes-confusion/#post-251205

That code works for me, this is what I see on page load: https://monosnap.com/file/4STaiMPH8iUsLAW4u7vNwQtTuiqNF7

Where are you adding that code to the site?


ComedieTriomphe

June 8, 2021 at 5:05 am

Hi Tony,

I added the code in a custom plugin, and repasted the code from your link just in case… Works on firefox, not on Chrome.

Can you think of a reason why?


Tony

  • Support Staff

June 8, 2021 at 5:44 am

None that I can think of, caching maybe?

Any ‘optimization’ plugins enabled?

Are you logged into both browsers when testing this?


ComedieTriomphe

June 8, 2021 at 5:46 am

Flushed the cache and deactivated the SiteGround Optimizer plugin, looks good now. Thanks, will continue to monitor and target what optimization troubled it (probably jQuery innit?)


Tony

  • Support Staff

June 8, 2021 at 5:55 am

Yeah if it’s messing with jQuery or moving JavaScript assets around, changing the load order etc it can cause issues.

You must be logged in to reply to this support post. Sign In or Register for an Account

Event Espresso