Support

Home Forums Event Espresso Premium This registration step could not be completed…

This registration step could not be completed…

Posted: January 4, 2019 at 8:16 am


kalhadi

January 4, 2019 at 8:16 am

Our clients are not able to register for events. This started happening yesterday suddenly and currently affecting our business. On the last screen when cc info is entered the wheel turns and then the error message appears. The strange thing is the authorize.net payment goes through but the user is not redirected to “My Account” and the error appears. You can experience the error if you enroll from any of the events:
https://amananet.com/training-classes/articulate-storyline-level-i/


Tony

  • Support Staff

January 4, 2019 at 9:11 am

Hi there,

We don’t run live payments during testing, if you’d like to switch your payment method to debug mode I’ll run through a test payment.

Also, you mentioned the user is not redirected to ‘My Account’, that isn’t something we do with Event Espresso, after payment they would see the ‘Thank you’ page, there’s no redirect from there so did you have some customizations done for that?

I can see you have/had wp_debug mode enabled and your logging errors, if that’s been disabling please re-enable it, I’ll need to see any errors thrown during the request.


kalhadi

January 4, 2019 at 9:18 am

Thanks for looking. The redirect is to the “Thank You” page (sorry not MyAccount. I mis-spoke). Transactions complete successfully for the “invoice me: option but fail for those that enter payment information.
I can make you an admin and you can enable/disable as needed.

Kal


Josh

  • Support Staff

January 4, 2019 at 9:23 am

We can’t enable WP_DEBUG as a WP admin, that’s something you’ll edit in your site’s wp-config.php file.


kalhadi

January 4, 2019 at 9:39 am

I just enabled WP_DEBUG


Tony

  • Support Staff

January 4, 2019 at 9:45 am

There’s a fatal error being thrown when EE is generating its messages:

PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 3072 bytes) in /wp-content/plugins/event-espresso-core-reg/core/third_party_libs/cssinliner/vendor/symfony/css-selector/Symfony/Component/CssSelector/XPath/XPathExpr.php on line 45

Which means your site is running out of memory at ~134MB.

Have you altered the message templates at all?

You could try bumping up the amount of available memory on your site, you can do that using:

define( 'WP_MEMORY_LIMIT', '256M' );

in your wp-config.php file. If you server has the memory available it may prevent the above, if not (and that fame error is thrown only using all over the 256MB available), there’s an issue with the customizations you’ve made to one of the message templates causing a memory leak.

  • This reply was modified 2 weeks, 1 day ago by  Tony.


kalhadi

January 4, 2019 at 9:53 am

I just bumped up the memory to 256MB.
Can you please check to see if the error still persists. I didn’t see that same error initially


Tony

  • Support Staff

January 4, 2019 at 9:58 am

I’m now getting an error stating my transaction declined (which is to be expected as I’m using dummy card info) so no more fatal error.

You’ll need to test a full payment to confirm it now works as expected.


kalhadi

January 4, 2019 at 10:00 am

Hi Tony, Sorry I had debug set to false when I increased to 256MB. Now it’s set to True and is at 256MB. Please check it again. I appreciate that.


Tony

  • Support Staff

January 4, 2019 at 10:06 am

WP_Debug doesn’t set the payment method into debug mode, that separate as you need specific sandbox credentials from your payment provider to use debug mode on a payment method.

However, the fact that I’m now receiving a declined messages from Auth.net (your payment provider) would usually means its working as expected now. The message I receive now is:

This transaction has been declined. (Reason Code: 2)

That’s expected because I’m using dummy card details and your payment method is in live mode, but it means that the fatal error that was happening earlier no longer is so it should work.

I’d recommend creating a test event with a $5 ticket and register onto that event yourself using ‘live’ card details to confirm it now works as expected.


kalhadi

January 4, 2019 at 10:11 am

This reply has been marked as private.


Tony

  • Support Staff

January 4, 2019 at 10:37 am

I added a $1 even

Some payment providers don’t allow $1 payments, which is why I recommend $5.

“failed to pass a hash check”

Are you sure that’s the exact error?

Can I hire you to fix and optimize the whole workflow and speed?

Sure, you can purchase a support token and we can work directly on this, however, if you are getting hash check errors that usually means the details you provided for the payment method are incorrect and I won’t have those, so you’ll need to check those either way.


kalhadi

January 4, 2019 at 4:25 pm

This reply has been marked as private.


Tony

  • Support Staff

January 5, 2019 at 5:16 am

The link I posted above will take you to a page you can purchase a support token on, here it is again:

https://eventespresso.com/product/premium-support-token/

Then go to your account page:

https://eventespresso.com/users/kalhadi/

Click the link to redeem your token just under you’re license keys and provide all of the requested details.


kalhadi

January 6, 2019 at 10:42 am

Update, I obtained a Authorize.net Transaction Key and everything seems to be working. Still no explanation why valid cards were getting declined all of a sudden.


Tony

  • Support Staff

January 7, 2019 at 4:00 pm

If a new Transaction Key fixed it then other than the fatal error from memory exhaustion the issue would have been with either an incorrect transaction key, or an issue on Auth.net’s end with the account/key.

Either way, I’m glad the above fixed it.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Tony 1 week, 5 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!