Support

Home Forums Community Forum This page didn't load Google Maps correctly.

This page didn't load Google Maps correctly.

Posted: June 28, 2016 at 3:49 am


Jaime Lopes

June 28, 2016 at 3:49 am

My site isn’t displaying google maps for e.g here.

After reading several other similar questions;
-I’ve confirmed that the address can be found by Google;
-Under the venue “Display Google Map for this venue?” is set to Yes;
-Under Google Maps “Activate Google Maps” is set to Yes.

Any ideas why it isn’t loading?

I see this error in the console:
Google Maps API error: MissingKeyMapError


Josh

  • Support Staff

June 28, 2016 at 8:44 am

You’ll need a Google Maps API key and to use the key, you update to Event Espresso 4.9.2, which adds an API key option.


Jaime Lopes

June 29, 2016 at 3:46 am

Thanks,

I added my API, but after loading the page once, the map appears for a second, then i get this error in the console: “This site has exceeded its daily quota for maps.”

I thought the limit was around 25000 loads on the free api, how can i exceed the limit after one page load?


Tony

  • Support Staff

June 29, 2016 at 4:11 am

That error would be thrown by Google themselves, so you would need to ask them.

When I view your site I don’t see an error for exceeding the quota, I see: Google Maps API error: RefererNotAllowedMapError https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error

It looks like you have not added your domain to the list of referrers. Set that within your google api manager and the map should work.


Jaime Lopes

June 29, 2016 at 4:17 am

Yeah, I was getting that error, so removed the referrer, that’s when I got the quota error. When I check the google developers console it says there have only been 2 requests, and says i have used 0 out of 25000…

btw, this is what my referrer settings are:
referrer


Tony

  • Support Staff

June 29, 2016 at 4:38 am

*.g1fourways.co.za/* allows for http://www.g1fourways.co.za

It does not allow for g1fourways.co.za – http://take.ms/oBGSq

Remove the . before g1 to allow for both.


Jaime Lopes

June 29, 2016 at 4:40 am

Wicked! its working now… Thanks!!!

The support post ‘This page didn't load Google Maps correctly.’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

If you would like help from the Event Espresso staff, then please purchase a support license right now so you can create a support topic in our premium support forums.

Status: closed

Updated by  Jaime Lopes 3 years, 3 months ago ago

Topic Tags

Tagged: , ,

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!