Home Forums Event Espresso Premium Thank you page popup

Thank you page popup

Posted: November 29, 2015 at 12:34 am

Chris Bouse

November 29, 2015 at 12:34 am

How can I edit the text in the popup which shows up on the thank you page after someone has registered? i don’t necessarily want to disable or hide it, but if i can not easily change it then ill go for disabling it.

Lorenzo Orlando Caum

  • Support Staff

November 29, 2015 at 2:20 pm

Hi Chris,

Are you referring to the congratulations messaging?

If so, please see this example:


Chris Bouse

December 1, 2015 at 6:12 pm

Yes sir, I am. Is there a way to change what it says? I don’t mind it but it is saying (to the effect) that your not approved registration has been submitted.

Thank you for the quick reply ๐Ÿ˜‰


  • Support Staff

December 2, 2015 at 4:27 am

Hi Chris,

The function Lorenzo linked to above is a way to change that text. You can add that to a Site Specific Plugin or within the themes functions.php file.

You can change:

'Your registration has been received! View your registration details by scrolling down.'

To return whichever text you prefer (it must still be wrapped within single quotes)

Chris Bouse

December 2, 2015 at 11:50 am

Roger that sir, I will give it a try and report back. Thank you for the response.


  • Support Staff

December 2, 2015 at 12:58 pm

Just let us know if you have any problems ๐Ÿ™‚

Chris Bouse

December 2, 2015 at 7:47 pm

Ok, I feel like this is completely going over my head. I inserted the code into my functions.php file and I did not fix the issue. Here is a screen grab of the popup.

Also, I don’t get the popup in Chrome just Safari. Any additional guidance you can offer would be greatly appreciated.

Chris Bouse

December 2, 2015 at 8:45 pm

After spending quite a bit of time trying to fix this we ended up installing a plugin called Quick Localisation. We just told it to look for “The %s message has been successfully sent.” (%s equaled the application status, which is set to not approved by default) and replace it with the desired text.

If you have an easy way to fix this issue which does not include using a plugin I would be willing to try it. Thank you all for your help trying to help me get this fixed. ~Chris

Lorenzo Orlando Caum

  • Support Staff

December 3, 2015 at 7:26 am

Hi, you could use a line of CSS to hide that. Could you reply with a link to your thank you page?



Chris Bouse

December 7, 2015 at 8:28 pm

Here is the link to the page:

Also, we were unable to get the popup to show while using Chrome but it worked great in safari. It would be nice to have a setting for it in future updates somewhere in the general settings or something.

Thanks again for the help ~Chris


  • Support Staff

December 8, 2015 at 12:39 pm

Hi Chris,

I think the pop up only gets displayed if your are logged into the site. I can advise adding the text to the actual thank you page to ensure it will be seen and read. You can use a number of hooks to add the information to the Thank you page. One of the hooks that can be used is the



Chris Bouse

December 8, 2015 at 7:54 pm

Awesome, thank you sir. I appreciate it.

The support post ‘Thank you page popup’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Chris Bouse 4 years, 5 months ago ago

Topic Tags


This topic is: resolved
Do NOT follow this link or you will be banned from the site!