Support

Home Forums Event Espresso Premium Thank You Page Authorize.net

Thank You Page Authorize.net

Posted: March 10, 2014 at 11:55 am


Chris Dudick

March 10, 2014 at 11:55 am

Hi Support Team,

I upgraded EE3 on my site and now I’m getting an unstyled Thank You page. Previously we had no issue with this. What can I do to fix this?


Lorenzo Orlando Caum

  • Support Staff

March 10, 2014 at 12:05 pm

Hi Chris,

Are you running any caching plugins or caching services on your site? If so, could you please clear the cache for those plugins/services?

Also, could you share a link to any event on your site?


Lorenzo


Chris Dudick

March 10, 2014 at 12:11 pm

Hi Lorenzo,

No, we don’t have caching on yet. Here is a test event: http://mysmallfactory.com/event-registration/?ee=11784

Thanks!


Lorenzo Orlando Caum

  • Support Staff

March 10, 2014 at 12:19 pm

Hi Chris,

Would you be able to grab a screenshot of what the page looks like?

The forums does not accept attachments but you can upload to WP Media or a free service like tinygrab.com or getcloudapp.com

I wonder if its sending you back to an https version of your site. That would cause this issue since there is a shared SSL on the site (http://cl.ly/image/2d1w1T0t421v).

Modern browsers like Chrome would block http links on an https page, thereby preventing certain page resources from loading.


Lorenzo


Chris Dudick

March 10, 2014 at 12:25 pm

The url is https but it doesn’t have mysmallfactory in it, it still has an authorize.net url


Chris Dudick

March 10, 2014 at 12:30 pm

here is my screenshot: https://dl.dropboxusercontent.com/u/12435367/event-espresso-screenshot.png


Lorenzo Orlando Caum

  • Support Staff

March 10, 2014 at 12:43 pm

I see that you are using Chrome. Could you right click on an item on the page and go to inspect element?

Do you see any blocked messages in the inspector?

If so, you’ll need an SSL certificate on the site so that those CSS files load correctly over https.


Lorenzo


Chris Dudick

March 10, 2014 at 12:52 pm

Yes, I see blocked messages, ok thanks Lorenzo. If I install ssl is there any additional configuration I need to do with EE?


Lorenzo Orlando Caum

  • Support Staff

March 10, 2014 at 12:55 pm

You won’t need to make any additional changes. It will correct the blocked resources issue and this warning:

http://cl.ly/image/2d1w1T0t421v


Lorenzo


Chris Dudick

March 10, 2014 at 3:44 pm

Do you know why this happened when I updated EE but not before last night? The checkout redirected to the thank you page no problem before the update.


Lorenzo Orlando Caum

  • Support Staff

March 10, 2014 at 3:56 pm

Were you running a very old version before you updated?

There is an option for Authorizenet SIM in EE payment settings for “Force HTTPS on Return URL.”

You could try turning that off but there is still a chance that a modern web browser will block loading of http content over https.


Lorenzo

The support post ‘Thank You Page Authorize.net’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Lorenzo Orlando Caum 5 years, 5 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!