Support

Home Forums Event Espresso Premium Switching to live Auth.net account doesn't record payment

Switching to live Auth.net account doesn't record payment

Posted: January 16, 2015 at 8:37 am


Della Baines

January 16, 2015 at 8:37 am

After updating my Authorize.NET setting in Event Espresso to use a live account instead of my sandbox one, the payment is no longer getting recorded. You can see in this screenshot, https://docs.google.com/file/d/0B3L74lrxcBqYeElWUWxNNXpCM0U/edit?usp=drivesdk. The one with ID 46 was made using the sandbox settings and the ID 47 was made using the live account. Why would it be leaving the ‘Paid’ amount as 0 only with the live account? I’ve tested it a number of times and there were no errors when registering and I successfully went to the Thank You confirmation page each time.


Tony

  • Support Staff

January 16, 2015 at 10:48 am

Hi Della Baines,

How are you switching the account?

If you view the transaction you should see a ‘Gateway Response’ field, is there anything in that field for the fail transaction using the live account?


Della Baines

January 16, 2015 at 11:11 am

Thanks for the quick reply! The gateway response is ‘This transaction has been declined.’. I’ve figured out that it was an error with the billing address not being correct. I entered the correct one and the payment was recorded.

Is this the intended functionality? Shouldn’t there be an error when submitting the payment info if the transaction is declined? I was sent to the thank you page event though it was declined.


Tony

  • Support Staff

January 16, 2015 at 11:16 am

If Auth.net redirects you, you will be returned to the thank you page.

The thank you page should display your current status, and also show if the payment was successful or declined, allowing you to retry with either the same payment gateway or another (if you have more than one active).

Did the thank you page not show the payment was declined?


Della Baines

January 16, 2015 at 4:58 pm

Thanks for the reply. This was the case, the error messaging has been hidden on the thank you page.

The support post ‘Switching to live Auth.net account doesn't record payment’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Della Baines 5 years, 4 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!