Support

Home Forums Event Espresso Premium Stripe stuck in loop

Stripe stuck in loop

Posted: September 10, 2022 at 7:47 pm


wkcde

September 10, 2022 at 7:47 pm

EE: 4.10.38.p
Stripe Add-On: 1.1.11.p

We have been using the Stripe Add-On successfully for awhile. Starting in mid-June, it stopped after the person has entered the card info and you click “Pay Now.” If I look in the network traffic, it is stuck in a loop trying to talk with Stripe continuously until you kill the page. It’s trying to post to r.stripe.com/0 and is getting “ErrorFetching: https://r.stripe.com/0

Things tried:

  • Disconnecting from Stripe and reconnecting – always connects fine
  • Turn off all plugins and switch to generic theme
  • Try both in debug mode and not – data does not seem to be reaching the stripe account either way.
  • Make sure EE and the Stripe add-on are both up to date.
  • Try in Chrome and Firefox – get the same thing

Not sure what else to try! I gotta believe someone else has hit this?

Thanks all!


Tony

  • Support Staff

September 12, 2022 at 10:09 am

Hi there,

We’ve not had any reports of this and I’ve just tested Stripe on a couple of different servers without any issue, so we’ll need to investigate this further.

Can you link me to an event I can run a couple of test registrations on?

Note we don’t run live payments (test payments on a live Stripe account are also against their TOS) so we’ll need the account connected in Debug mode to test this.


wkcde

September 14, 2022 at 7:59 pm

https://staging23.wilmingtonkennelclub.org/classes/show-go-rally/

This is on the staging site which is set in debug mode. Ignore all the shortcode messiness… it’s from switching into the 2022 theme for simplicity of debugging.

The setup screen confirms it is connected to the Stripe account. The Stripe account is also set in test mode. Thanks for the help!


wkcde

September 14, 2022 at 10:16 pm

Further insights:
* If I set the Stripe “show by default” to “No” … the radio button does not work to show the form. But I’m not seeing any error triggered by it either. I turned it back to “Yes” for your review.
* I see you now have a Square add-on. I tried installing that but it does not seem to process either – in a similar way.
* I tried again in Firefox – same behavior
* Checked the requests in Stripe’s developer area but it’s not seeing the requests.
* I looked up the last successful transaction using the Stripe add-on – June 10. We had been using it successfully before that for quite some time.

I sure seems like some conflict – or security block – or config setting. But I can’t find it. The only plugins activated right now are EE, EE-grid layout, and EE-Stripe

Thanks for any insights!


Tony

  • Support Staff

September 15, 2022 at 4:46 am

Hmm, yeah, that’s… odd!

I’ve asked one of our developers to take a look into this as I can’t see why the above would happen, I will post any feedback they give here (may take a little due to time differences).


Tony

  • Support Staff

September 15, 2022 at 5:29 am

Ok, I assume there are no log entries in Event Espresso -> Payment methods -> logs that are related to this?

Can I check with one of our test accounts to confirm this isn’t account-specific? If so I’ll need temp login details so I can disconnect your account and log into ours.

If that’s ok you can send temp credentials using this form:

https://eventespresso.com/send-login-details/


wkcde

September 15, 2022 at 1:50 pm

Yes – the logs in the staging site have a bunch of…
“payment_intent No payment intent ID present, so no request to create a payment intent created.”

Credentials sent soon.


Tony

  • Support Staff

September 16, 2022 at 6:54 am

Thank you, one of our developers is currently investigating this.

I’ll post any feedback given for this here, we’ll likely need to push an update to fix it (although I still cannot reproduce it on my test sites).

The support post ‘Stripe stuck in loop’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso