Support

Home Forums Event Espresso Premium Stripe SCA Auth causing payment declined?

Stripe SCA Auth causing payment declined?

Posted: September 4, 2019 at 3:15 pm


Steve

September 4, 2019 at 3:15 pm

Hi There,

I’m in the process of switching up SCA Authentication for Stripe (as we’re EU Based).

I’ve connected Stripe, I’ve switched to the new cart method. I’ve set collect Billing Address Collection on and off.

Every time I put through a test payment, I get a decline message and a decline email sent out to the customer; when then completing SCA/3D Secure enhanced verification, the payment then goes through and tickets are issued

This is super confusing for the customer; their payment hasn’t been declined, its just part of the process to request additional verification.

Any ideas what might be causing this / what setting I might have toggled incorrectly?

Also, can I use an adjustment to change the names of the address fields on the stripe cart? e.g. it says zip code.

Finally, what’s the advantage of collecting billing address? I can’t really see one as I have it on file anyway but perhaps I’m missing something? Is this now needed for SCA?


Josh

  • Support Staff

September 4, 2019 at 3:35 pm

Hi,

You shouldn’t be seeing and getting an email about the card being declined. That’s not normal even if extra verification is needed. May I ask how exactly are you testing this, and is this using the Debug Mode option set in the Stripe payment methods settings?

Finally, what’s the advantage of collecting billing address? I can’t really see one as I have it on file anyway but perhaps I’m missing something? Is this now needed for SCA?

The credit card industry says it can help reduce fraud rates as the merchant can ask the bank to verify the address provided with what they have on file for the card, this is known as AVS (Address Verification Service). Stripe makes it so it’s optional to capture billing address.


Steve

September 9, 2019 at 7:21 am

Hi Josh,

I’m in debug mode both in Stripe and EE.

Using the various SCA test card IDs

I put it through as a normal transaction, and goto payment process,

At the point at which the payment starts processing, the extra verification is triggered. This seems to generate a decline, but the SCA window pops, then you complete that and it goes through.

When you get through to the summary screen it shows this in the transaction table to the user as well.

Would seem that EE is interpreting the “further auth needed” as a decline, when it should be a pending or something.

Let me know what else I need to do, this is quite urgent now as Stripe will shutdown our access…


Josh

  • Support Staff

September 9, 2019 at 11:24 am

Hi Steve,

I checked with the developers about this and what we’ve found so far is there will need to be a new payment status added to replace the usage of declined, to allow for something other than declined to continue the payment flow. Until that’s been added, what you could do in the meantime is deactivate the Payment Declined message type. The message types are managed in Event Espresso > Messages > Settings, to deactivate the Payment Declined message type you click and drag the “payment declined” message type over to the Inactive box.


fffunction

September 12, 2019 at 6:05 am

Hi there,

I’m experiencing an identical problem, the receipt of a declined email, then a successful payment email:

https://cloudup.com/c6hwHv9Kqfp

And also on the success page on the website:

https://cloudup.com/cf_WjB2xKjM

Can you give us an indication on when the new payment status will be available? SCA is 2 days away, and de-activating the “payment declined” message is surely going to cause other problems for customers when they have their payment declined?

Thanks,
Ben


Josh

  • Support Staff

September 12, 2019 at 6:13 am

Hi Ben,

An update to the Stripe add-on was released yesterday, and it includes the fix.


fffunction

September 12, 2019 at 6:14 am

Awesome, thanks Josh!


fffunction

September 13, 2019 at 3:11 am

Hello again Josh.

I’ve been able to get the Strips Gateway working, but have an issue with buttons. The Stripe form has a Pay Now button, and underneath that I have the old method’s button. You can see it in this screenshot:

https://cloudup.com/cKn_wweKMpn

Is this expected behaviour?

Thanks,
Ben


Tony

  • Support Staff

September 13, 2019 at 5:43 am

Hi there,

Do you mean the ‘Complete my registration’ button?

If so that’s not from the old Stripe payment method, it’s the finalize registration button from single page checkout and its expected to be there.

May I ask what issue the button is causing?


fffunction

September 13, 2019 at 7:12 am

Hi Tony,

Yes, sorry – the ‘Complete my registration’ button.

The issue is poor usability – it’s confusing for the user to have two buttons appearing to do the same thing, and in this case the user never needs to use the “Complete my registration” button, as ‘pay now’ completes the process and moves on. Also they can’t use it anyway as it’s disabled.

B


Tony

  • Support Staff

September 16, 2019 at 4:21 am

In your example screenshot, those buttons still appear to serve a different purpose.

One states ‘Pay Now’ and the other ‘Complete My Registration’, if you know you’re paying for a product (you selected a ticket with a cost) your next step would be to pay for said produce, right?

In that case you would click to Pay and EE automatically finalizes the registration for you, the other button is disabled as you can’t finalize without selecting a payment method and running through whatever that payment method needs you to do.

That finalize button is available within SPCO as you can use various payment methods, for example, when you select an offline payment method it will continue to show just that Complete My Registration button to allow you to finalize. For most other on-site payment methods it will also use that button. Stripe, however, is different as it is a sort of hybrid off-site but looks on-site payment method and needs a separate button to trigger the payment request.

You could use some CSS to hide that button whilst it is disabled if you prefer:

#spco-go-to-step-finalize_registration-submit:disabled {
    display: none;
}

Add that to Appearance -> Customize -> Additional CSS.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Tony 3 days, 5 hours ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!