Support

Home Forums Event Espresso Premium Stripe integration error again

Stripe integration error again

Posted: October 12, 2018 at 12:33 pm


drkings1

October 12, 2018 at 12:33 pm

Hi there,

This is a continuation of the thread started 3 weeks ago:

https://eventespresso.com/topic/stripe-integration-error/

I’ve now asked my hosting company to increase the length of URLs allowed.

I’ve used stripe connect, which appeared to go all the way through the process without an error this time. (Username and password accepted, final blue button clicked, no error messages).

But when I look in event espresso it does not say that Stripe is connected.

Instead the Stripe Connect button is still there:

https://screencast.com/t/LcgX6dDL7
https://screencast.com/t/W2i4miD1jyR7
https://screencast.com/t/9H4INTogZ

When I do a test payment the same error as before comes up:

https://screencast.com/t/aBGPhWXK

You did not set a valid publishable key. Call Stripe.setPublishableKey(). For more info see https://stripe.com/docs/stripe.js

Any suggestions as to how to proceed from here please?

Many thanks

Daniel


Josh

  • Support Staff

October 12, 2018 at 12:40 pm

Hi Daniel,

Server issues aside, if you have a security plugin that’s actively blocking/filtering long URIs you could unset the option within the Security plugin’s settings that enables that feature. Or temporarily deactivate the security plugin(s) installed on the site, then try connecting to Stripe again.

If the underlying cause is a server limit, you can contact your host and ask then to raise the limit again. Under Apache, the limit is a configurable value, LimitRequestLine.


drkings1

October 15, 2018 at 11:04 am

Thanks Josh,

Are you convinced that the issue is one with long URLs which are blocking the Stripe Connect?

I did have a security plugin that was blocking long URLs, but I was able to switch off that feature. But it didn’t solve the problem.

My host did raise the limit on long URLs.

The support team emailed me to say:

I have added the following line to the .htaccess file:

SubstituteMaxLineLength 10m

Did they go about it the wrong way or did they not raise it enough?

Thanks

Daniel


Josh

  • Support Staff

October 15, 2018 at 11:41 am

Hi Daniel,

Are you still getting a http error 414 when you try to connect the site, or is it a different error now?


drkings1

October 15, 2018 at 12:11 pm

No. This time no error came up.

The screen cleared when I hit the blue button without any error being displayed.

I assumed that this was a sign that it had managed to connect without error. But perhaps this is wrong since I’m not getting the “Connected” badge you spoke of.

But then when I do the test payment I get the “you did not set publishable key error” (see screenshot above).


Josh

  • Support Staff

October 15, 2018 at 12:18 pm

Hi,

Here’s what you’ll see when it’s connected:

https://slack-files.com/T02SY781D-FDEQGATKP-9dffddade6

If you do not see a checkmark with the word “Connected” next to it, along with a button that says “Disconnect”, that means your site is not connected.

Have you tried temporarily deactivating all security plugin, then go to the payment methods settings page, then connect with those security plugins deactivated?


drkings1

October 16, 2018 at 8:31 am

OK that’s clear now.

So the connection isn’t happening, because I don’t see what you showed on the screenshot.

I sign in and EE Connect says I’ve successfully authenticated.
Then it invites me to click the blue button to complete the authentication process.
The gear wheel turns for while and then returns me to the blue button saying:
“Connect with stripe” as if nothing has happened.

There is no error message, but yet it is not connected.

I have now tried deactivating all security plugins, but sadly it is not making any difference. It still happens exactly as I’ve described above.

Any suggestions as to how to proceed next?


Josh

  • Support Staff

October 16, 2018 at 8:35 am

You could try deactivating all plugins besides Event Espresso & its add-ons. If that also does not help, you could check the browser’s error console for a JavaScript error.


drkings1

October 17, 2018 at 10:19 am

Hi Josh,

I tried deactivating all plugins besides EE, but that didn’t help.
I tried using a different browser, but that didn’t help either.
I checked the console for a JavaScript error, but nothing came up at the relevant time.

(There was a minor JS error, but it didn’t occur when I was doing the Stripe connect phase – Mixed Content: The page at ‘https://staging2.presencetraining.co.uk/wp-admin/admin.php?page=espresso_payment_settings’ was loaded over HTTPS, but requested an insecure image ‘http://staging2.presencetraining.co.uk/wp-content/uploads/2015/02/logo_icon_2-150×150.png’. This content should also be served over HTTPS.)

Any suggestions as to where to look next?


Josh

  • Support Staff

October 17, 2018 at 10:53 am

I don’t think your site will allow connecting to Stripe via the Connect API. What you can do instead is use the older method where you just enter your Stripe API keys in the settings.

The fields for those are removed in the newer version of the Stripe gateway, but you can restore them by adding this code:

add_filter(
'FHEE__EE_PMT_Stripe_Onsite__generate_new_settings_form__hide_key_fields', 
'__return_false'
);

You can add the above to a functions plugin. After adding the code, please be sure to activate the plugin on the WordPress > Plugins page.

Once those fields have been restored, you can follow this part of the Stripe set up guide:

https://eventespresso.com/wiki/stripe-payment-gateway/#locate

The support post ‘Stripe integration error again’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 1 month, 3 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!