Support

Home Forums Event Espresso Premium Stripe Gateway Failing

Stripe Gateway Failing

Posted: September 19, 2012 at 3:15 pm


Keith Schmader

September 19, 2012 at 3:15 pm

Hello, I have configured the Stripe gateway on my site; however payment is failing. Is there a log file I might check?


Keith Schmader

September 19, 2012 at 3:19 pm

The specific error is “Looks like something went wrong. Please try again or notify the website administrator.”


Keith Schmader

September 19, 2012 at 3:51 pm

I also notice that the HTTPS redirection only occurs after the credit card details are entered, not before.


Keith Schmader

September 19, 2012 at 6:37 pm

I’ve also just updated my site to 3.1.27 and only have the Event Espresso Plugin and Permissions module installed.

Why am I receiving the error when I try to process a Credit Card using the Stripe gateway?

Is there an error log?

Shouldn’t the site be in HTTPS mode when the credit card is entered the first time and not after the fact?


Seth Shoultes

  • Support Staff

September 19, 2012 at 10:58 pm

I believe the site should be HTTPS mode when processing the transaction. Do you have an HTTPS plugin installed that forces the transactions and payment pages to HTTPS?


Keith Schmader

September 20, 2012 at 6:10 am

I do not have such a plugin installed. Will install and see if that resolves my error with the Stripe Gateway processing.

If it does not could you please answer some of my other questions, thanks.


Keith Schmader

September 20, 2012 at 6:17 am

Installed WordPress HTTPS and the registration page and checkout page are now in HTTPS mode; however I still receive this error immediately after trying to make a payment

ERROR: Failed to charge the card.
Looks like something went wrong. Please try again or notify the website administrator.


Sidney Harrell

September 20, 2012 at 1:35 pm

Hey Keith,
The payment page itself doesn’t need to be https, since when the payment page is transmitted to the customer, it is blank. What is important is that the Thank You page is https, since it is the POST to that page that contains the credit card information. You can check the log of the transaction in uploads/espresso/logs/espresso_log.txt, or in the transaction_details field in the db record for the attendee.
Of course, from a user perspective, you’ll want to make the payment page https, just to give a warm and fuzzy feeling to the customer.


Keith Schmader

September 20, 2012 at 2:24 pm

Here are some lines from the espresso_log.txt file…these are being recorded each time a payment fails

[09.19.12 21:49:53][payment_page.php][event_espresso_pay] [Payment for: Schmader, Keith|| registration id: 1-505a3d81a3ac7|| transaction details: a:2:{s:6:”status”;i:0;s:9:”error_msg”;s:26:”Failed to charge the card.”;}]//end
[09.19.12 21:50:03][payment_page.php][event_espresso_pay] [Payment for: Schmader, Keith|| registration id: 1-505a3d81a3ac7|| transaction details: a:2:{s:6:”status”;i:0;s:9:”error_msg”;s:26:”Failed to charge the card.”;}]//end


Keith Schmader

September 21, 2012 at 5:49 am

Hello, I need support for the Stripe Gateway.


Keith Schmader

September 21, 2012 at 10:35 am

The stripe gateway is not working on my website. I purchased Event Espresso with the understanding that it worked with the Stripe Gateway. I need some support to get this working. Thank you.


Seth Shoultes

  • Support Staff

September 21, 2012 at 11:22 am

Kieth,

Have you been in contact with Stripe about the issue?


Seth Shoultes

  • Support Staff

September 21, 2012 at 11:50 am

I just tested the Stripe gateway on our sandbox site and the payment went through just fine (screenshot: http://www.screencast.com/t/g73jyx9cY).

I would contact Stripe (support@stripe.com) if I were you and see if they can access the specific reason the card is failing.


Keith Schmader

September 21, 2012 at 12:36 pm

Got it, must have USD and not a $ or anything else in the Stripe Currency Symbol box!

The support post ‘Stripe Gateway Failing’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Keith Schmader 8 years, 6 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!