Support

Stripe

Posted: April 27, 2021 at 9:42 am


SteveMBragg

April 27, 2021 at 9:42 am

Strpe have informed us that your Strip Payment module (plugin) is not SCA compatible and needs upgrading.

Please advise

Regards

Steve B


Tony

  • Support Staff

April 27, 2021 at 2:48 pm

Hi Steve,

The Stripe payment method has 2 integration types, Checkout and Elements.

Checkout is now considered legacy by Stripe and is not SCA compliant, Elements is.

If you go to Event Espresso -> Payment methods -> Stripe.

Is ‘Integration Type*’ set to ‘Stripe Checkout’ or ‘Stripe Elements’?

If Checkout, switch to Elements and save, then retest the integration works as expected on your site.


SteveMBragg

April 28, 2021 at 1:49 am

It is set to Elements but Stripe are saying that it is none compliant. They are also saying you are using Magento?


Tony

  • Support Staff

April 28, 2021 at 2:26 am

Huh? Event Espresso is built on top of WordPress, it only works with WordPress and can not be run on Magento.

Can you link me to an EE event I can view this on?


SteveMBragg

April 28, 2021 at 3:20 am

Hi Tony

I get what you are saying and I have had this argument with them! Everytime we log into Stripe there is a SCA warning. I shout at them and they come back to me every time to say the issue is Event Espresso with Magento. I have tried telling them that we are not using Magento, they clear the error message and a few days later it comes back and we end up in the same loop!!

They are insistent the link to Magento is from EE and I know that is bizarre!

Anyway I have just had a go at them again and will have to see what they say.

Steve

You must be logged in to reply to this support post. Sign In or Register for an Account

Do NOT follow this link or you will be banned from the site!