Support

Home Forums Event Espresso Premium Split: Not getting registration emails

Split: Not getting registration emails

Posted: March 11, 2020 at 6:28 pm


Craig Schwartz

March 11, 2020 at 6:28 pm

Hi, Tony

Sorry to piggyback on this support ticket but I believe I may be having the same issue. My client said they are receiving sporadic email registration notifications – . I did check the backend as you mentioned above and I see all messages there. Client mentioned the following … “stopped receiving emails from Event Espresso after someone registers for a class. We are getting an email from Authnet confiming that a credit card payment was made, but not the separate email from Event Espresso”.

Howard


Josh

  • Support Staff

March 11, 2020 at 9:50 pm

Hi Howard,

If the Event Espresso > Messages > Activity list table shows the emails were sent, then the emails may have been flagged as spam. Can you check if other emails sent by your site are received, like a new user account email or password reset email? Or you could use this plugin:

https://wordpress.org/plugins/check-email/


Craig Schwartz

March 15, 2020 at 4:01 pm

Hi, Josh

Would there be an update issue, or conflict with another update installed, etc?

I will look into what you mentioned above. The client sent me a spreadsheet of confirmation emails in the backend and they said that since January 8th only a few confirmation emails have been received. Get back to you shortly on what we find out…

Thanks for your help!

Howard


Tony

  • Support Staff

March 16, 2020 at 7:31 am

Would there be an update issue, or conflict with another update installed, etc?

That is unlikely and Event Espresso -> Messages -> Message activity is showing the messages as sent (a green status bar) then it means everything on EE’s side worked as expected, the message was triggered, generated and ‘sent’ to your server without any issues.

If they then aren’t received after that then the issue is with the mail servers on the way (either the sending or receiving servers) flagging the emails as spam.

Using check email as above allows you to confirm if plain text emails function as expected, but unfortunately, it won’t tell you if EE’s HTML emails are being flagged so I recommend switching to a transactional email service.

We have some listed here:

https://eventespresso.com/wiki/postmark-app-mandrill-transactional-email-handling-services/

You’ll likely find the emails then ‘just work’ but if not, the dashboard for any of those services will give you much more information on why they aren’t working than EE can.


Craig Schwartz

March 18, 2020 at 6:19 pm

Hi, Tony

The client said that they did receive emails for a new member signup as well as password request. I one case, yesterday during an hour or so window, 4 reservations were processed online through EE, one of those 4 were received in email form, the other 3 were not – but all 4 are in the backend in MESSAGES activity. Does this help any? or still strongly feel its a mail server issue selecting certain ones and marking them as spam?


Tony

  • Support Staff

March 19, 2020 at 3:13 am

If they show as sent in message activity then yes, it is still most likely a mail server issue.

You can think of it similar to physically posting a letter, you post your letter into the post box and then whatever happens from there is out of your control.

It’s similar in EE, we generate the email and pass it over to the mail server (which simply returns a ‘true’ or ‘false’ response) from there EE has no control of what happens or where it goes.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Tony 1 week, 4 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!