Support

Home Forums Event Espresso Premium Slug and Venue Update not saving

Slug and Venue Update not saving

Posted: January 2, 2019 at 4:49 am


killerkonceptz

January 2, 2019 at 4:49 am

I duplicated one event a few different times since the tickets are setup just the way I wanted them to be. I went back to the duplicates and updated the event names and then updated the slugs. After updating them, the system reverts back to the original slug. I then tried a different slug just in case, but that does not seem to make a difference. No matter what I put in, it always reverts back to the original slug. Similarly, I select a venue from the drop down box, but it reverts back to “Select a Venue.”

This is the first time experiencing this problem. Note: This is also happening with other inactive and active events.

max_input_vars = 1000 (so I am not sure if that is it).

Recommendations?


Tony

  • Support Staff

January 2, 2019 at 6:56 am

Hi there,

max_input_vars = 1000 (so I am not sure if that is it).

Possibly, the quickest way to tell is to update that value and retest.

Depending on your host you may be able to change that value from within your control panel, if not I’d recommend contacting your host and have them update it for you.

Or, you can open up from dev tools on the event editor, in the elements tab search for ‘input’ and see how many search results are found, if more than 1000… you need to update the above setting.

How many tickets/datetimes do you have on the event(s)?


killerkonceptz

January 2, 2019 at 9:51 am

I am not sure about the dev tools that you reference. Are you referencing something from your software, from Chrome, or something else?


Tony

  • Support Staff

January 2, 2019 at 10:00 am

My apologies, I missed half my sentence above! (Pretty sure I typed it out, strange). Take 2:

Or, you can open up Chrome Dev Tools ( Like this – http://take.ms/Th33y ) on the event editor, in the elements tab search for β€˜input’ and see how many search results are found, if more than 1000… you need to update the above setting.


killerkonceptz

January 3, 2019 at 12:37 am

Input count was 1267, and the max listed was 1000, so I called HostGator to have them update it in either php.ini or htaccess file. They created the ini file and listed it in the htaccess. I went in and edited it to max=2000 instead of 1000 and saved it. I reopened the file and saw that the update save correctly. However, when I log back in and check it out through the maintenance system info screen via the Event Espresso plugin, it still reads 1000, and the problem of updating the slug or selecting the venue still persists.

Is there something I am missing?


killerkonceptz

January 3, 2019 at 1:00 am

This reply has been marked as private.


Tony

  • Support Staff

January 3, 2019 at 4:44 am

However, when I log back in and check it out through the maintenance system info screen via the Event Espresso plugin, it still reads 1000

EE simply reads the value from the server using ini_get so if it still shows as 1000, the changes the host made have not been applied.

As the changes have been applied to a php.ini/user.ini file Apache would have needed to have been restarted for those changes to have been applied on the server, has that been done on the server? If you don’t know you’ll need to check with the host (as it appears a restart has not been done).

and the problem of updating the slug or selecting the venue still persists.

If EE still reads 1000 then nothing has actually changed, so the issue will be the same as it was before.


killerkonceptz

January 3, 2019 at 4:53 pm

This reply has been marked as private.


Tony

  • Support Staff

January 4, 2019 at 3:09 am

This reply has been marked as private.


killerkonceptz

January 4, 2019 at 4:31 pm

I copied that one over, and it did not take. The maintenance system info still shows 1000. I’m a bit lost on this. This has delayed our push to go live with the event for two plus days now!


Josh

  • Support Staff

January 5, 2019 at 11:30 am

This reply has been marked as private.


killerkonceptz

January 5, 2019 at 1:53 pm

This reply has been marked as private.


killerkonceptz

January 5, 2019 at 2:52 pm

This reply has been marked as private.


killerkonceptz

January 5, 2019 at 3:31 pm

FIXED!!!

Hosting Company was able to escalate it to another department, and that department found that their code for the php.ini file did not have everything it needed in it nor was it in the best place so the plugins could see it!

Thank you for all of your help on this! We really appreciate it!


Tony

  • Support Staff

January 7, 2019 at 8:09 am

Great, I’m glad they got it fixed up for you πŸ™‚

If you run into any more problems please do let us know.

The support post ‘Slug and Venue Update not saving’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 months, 2 weeks ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!