Support

Home Forums Event Espresso Premium Site inoperative. Fatal error: Class 'Event_Espresso_Widget' not found

Site inoperative. Fatal error: Class 'Event_Espresso_Widget' not found

Posted: July 9, 2012 at 4:10 pm


studioarthouseinc

July 9, 2012 at 4:10 pm

Cannot login to wp-admin or display site. Get message Fatal error: Class ‘Event_Espresso_Widget’ not found in /home/dfwartcl/public_html/wp-includes/widgets.php on line 324

Updated WP to latest a couple of days ago and updated Event Espresso (and 2 options – I think multi-event and recurring) via plugins panel. Everything looked OK, new versions, etc.

Now we can’t login at all, cannot access site, cannot access admin. dfwartclasses.com


Josh

  • Support Staff

July 9, 2012 at 4:16 pm

You’ll need to access the site files and temporarily rename the eventespresso plugin directory, that will deactivate the plugin.

Then go into the /wp-content/uploads/espresso/templates directory and rename the templates directory to something like /wp-content/uploads/espresso/templatesOLD

Then rename the eventespresso plugin directory back to the original name. Then re-activate.


studioarthouseinc

July 9, 2012 at 4:38 pm

Tried a couple of times. Fatal error returned each time I activated. Even deactivated some additional EE plugins before attempting activation. No luck.

Renamed EE plugin folder, renamed templates folder, re-re-named EE plugins to original, logged in to admin, activated EE, boom.


Josh

  • Support Staff

July 9, 2012 at 4:42 pm

Try switching to the twentyeleven theme and deactivating any plugins that add their own widget before reactivating Event Espresso.

Also, if you go into wp_config, try turning on wp_debug to true, that might output more debug info with the fatal error that we can use.


studioarthouseinc

July 9, 2012 at 5:02 pm

Nope. Same error when I attempt to activate EE. I deactivated ALL plugins and switched template. Every time I get to the activate EE step, boom


Josh

  • Support Staff

July 9, 2012 at 5:20 pm

I believe I have admin + FTP credentials from when we installed this. Is it okay if we take a look under the hood?


studioarthouseinc

July 9, 2012 at 5:24 pm

yeppers


Josh

  • Support Staff

July 9, 2012 at 6:17 pm

I uploaded a fresh copy of Event Espresso via FTP (I kept getting errors when I tried to upload a new copy via the built in WP plugin installer).

When you updated to the latest version of Event Espresso, was that via the automatic update, or was it by deactivating the old and uploading the new?

Update: No errors thus far, let us know if you run into any problems.

  • This reply was modified 8 years, 6 months ago by  Josh. Reason: update


studioarthouseinc

July 10, 2012 at 8:29 am

Did the update via automatic update on the plugins page.

Thanks for fixing it. Re-install would have been my next step.

The support post ‘Site inoperative. Fatal error: Class 'Event_Espresso_Widget' not found’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  studioarthouseinc 8 years, 6 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!